[NTG-context] Lua error in latest beta?

Alan Bowen bowenalan03 at gmail.com
Mon Apr 29 20:43:17 CEST 2019


When I process files using the latest standalone  ConTeXt  ver: 2019.04.29
08:52 MKIV beta  fmt:  LuaTeX, Version 1.10.0 (TeX Live 2019)), I now get
the following error message:

lua error       > lua error on line 8 in file env_Brill-01.tex:


...eXt/tex/texmf-context/tex/context/base/mkiv/font-oup.lua:1317: bad
argument #1 to 'concat' (table expected, got number)

The error log is as follows:

return {
 ["filename"]="env_Brill-01.tex",
 ["lastcontext"]="\
\\font_helpers_low_level_define ...nsize }{\\m_font_designsize
}\\scaledfontmode \
                                                  \\relax \\ifcase
\\scaledfont...\
\\font_fallbacks_clone_unique ...w_level_define
{#1}\\v_font_identifier_basic \
                                                  \\csname
\\v_font_identifier...\
l.8 }\
    \
\\font_fallbacks_prepare #1->\\clf_fontcollectionprepare {#1}\
                                      \
\\font_fallbacks_prepare_indeed ... \\lastrawfontcall
\\font_fallbacks_prepare #1\
                                                  \\endgroup \
<inserted text> ...nt_fallbacks_prepare_indeed \\m_font_fallbacks \
                                                  \\fi \\fi \
...\
l.215 \\setupbodyfont[mainface, 10pt]\
                                   ",
 ["lastluaerror"]="...eXt/tex/texmf-context/tex/context/base/mkiv/font-oup.lua:1317:
bad argument #1 to 'concat' (table expected, got number)",
 ["lasttexerror"]="?",
 ["linenumber"]=8,
 ["luaerrorline"]="1317",
 ["offset"]=10,
}

This files process as they should with earlier versions. I will try to
produce an mwe if needed but hope that it is not.

Alan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20190429/c9120587/attachment-0001.html>


More information about the ntg-context mailing list