[NTG-context] underscore hyphenation in LMTX

Hans Hagen j.hagen at xs4all.nl
Mon Apr 29 10:57:42 CEST 2019


On 4/27/2019 1:51 PM, Pablo Rodriguez wrote:
> Dear list,
> 
> I have the following sample:
> 
>      \startluacode
>      function document.addfunnyhyphen(tfmdata)
>          local underscore = utf.byte("_")
>          local char       = tfmdata.characters[underscore]
>          tfmdata.characters[0xFE000]   = {
>              width    = 0,
>              height   = 0,
>              depth    = 0,
>              commands = {
>                  { "right", -char.width },
>                  { "down", char.depth },
>                  { "slot", 1, underscore },
>              }
>          }
>      end
> 
>      utilities.sequencers.appendaction("aftercopyingcharacters","after",
>          "document.addfunnyhyphen")
>      \stopluacode
> 
>      \definehyphenationfeatures
>            [whatever]
>            [righthyphenchar="FE000]
> 
>      \setuphyphenation[method=traditional]
>      \sethyphenationfeatures[strict, whatever]
> 
>      \setuppapersize[A10, lanscape]
> 
>      \starttext
>          \startmakeup[standard]
>          \hsize\zeropoint
>          \tt definebodyfont
>          \stopmakeup
>      \stoptext
> 
> I get the underscore hyphenation with latest ConTeXt beta (LuaTeX-1.10),
> but not with latest LMTX (LuaTeX-2.0).
> 
> Am I missing something here?

use slot '0' instead of '1' (i'll catch it anyway)

Hans


-- 

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list