[NTG-context] LMTX: 32-bit binaries for 64-bit system

Christian Prim christian.prim at gmx.ch
Sat Apr 6 11:04:30 CEST 2019


Hello

Today I tried to update the lmtx-installation on 64-bit Linux. The update
worked fine, but now I get:
# context
/home/username/lmtx/tex/texmf-linux-64/bin/context: No such file or
directory

Same for mtxrun.

Redo a fresh install doesn't work either.
# ./install.sh
/install.sh: 94: ./install.sh: /home/username/test/bin/mtxrun: not found

Digging in the problem I found, that the 64-bit installer has 32-bit
binaries. The same as in the 32-bit installation. On a system with
compatibility libraries the new install works, but on a pure 64-bit system
there is a problem.

Could you please fix or tell me what I miss.

Thanks
Christian

PS.: My architecture was correctly detected:
platform : linux-64

# file mtxrun -- gives for the file in the installer (
http://lmtx.pragma-ade.nl/install-lmtx/context-linux-64.zip):
mtxrun: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV),
dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 3.2.0,
BuildID[sha1]=729a29022162787ac1c5e5e48353a6ec37cce6b7, stripped

Exactly same sha1 as for 32-bit Linux mtxrun
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20190406/a1dec45c/attachment.html>


More information about the ntg-context mailing list