[NTG-context] follow up

Taco Hoekwater taco at elvenkind.com
Tue Apr 2 20:38:21 CEST 2019



> On 2 Apr 2019, at 17:11, Hans Hagen <j.hagen at xs4all.nl> wrote:
> 
> On 4/2/2019 4:18 PM, Ulrike Fischer wrote:
>> Am Tue, 2 Apr 2019 15:58:18 +0200 schrieb Floris van Manen:
>>>> indeed on preview no x shows up but it does in other viewers
>>>> 
>>> 
>>> Not just the x.
>>> In the second example the s will disappear, be shows up if you add some extra digits, and then dropping the 2
>> I don't have a mac and can't reproduce the problem. But the missing
>> char seems to be always the last one in the beginbfchar/endbfchar
>> list.
>>> The OSX preview is flaky but i’d assume the output of both context version would be similar (enough)
>> The new context adds new lines inside the beginbfchar/endbfchar
>> block. Perhaps this confuses preview and it drops the last entry.
> it is indeed the last one that is the issue but changing spacing or adding dummies doesn't help

More likely the problem it has is due to the omitted /CIDSet in the font descriptor. 

The error is in the display engine, not the text extractor (since cut&paste work ok).
And that means the problem is almost certainly not the cmap. The only other non-trivial
difference I saw in the old vs. new pdf was that no longer present /CIDSet. 

Unf., generating one in the text editor is bit beyond me-on-the-could mode, so I can
not be certain of that although it seems likely (I checked with FF that the two glyphs
are indeed in the embedded font subset and in the exact slots the pdf says they have, so 
that is also unlikely to be the problem.)

Best wishes,
Taco



More information about the ntg-context mailing list