[NTG-context] Welcome to LMTX

Paul Hoffman nkuitse at nkuitse.com
Tue Apr 2 19:35:40 CEST 2019


On Tue, Apr 02, 2019 at 04:41:40PM +0200, Hans Hagen wrote:
> On 4/2/2019 3:15 PM, Paul Hoffman wrote:
> >On Mon, Apr 01, 2019 at 04:55:11PM +0200, Hans Hagen wrote:
> >>The average user will probably not notice many differences but nevertheless,
> >>when you are in for something new, you can give it a try:
> >>
> >>      http://www.pragma-ade.nl/install.htm
> >
> >I would love to try LMTX, but all of my computers are 32-bit.  Is there
> >any chance of a 32-bit compile for Linux?
> I tried to compile one but have no clue if it works so you need to check it.

It doesn't work for me:

------------------------------------------------------------------------
# sh install.sh
/usr/local/lmtx/bin/mtxrun: /lib/libm.so.6: version `GLIBC_2.23' not found (required by /usr/local/lmtx/bin/mtxrun)
cp: cannot stat '/usr/local/lmtx/tex/texmf-linux/bin/mtxrun': No such file or directory
cp: cannot stat '/usr/local/lmtx/tex/texmf-context/scripts/context/lua/mtxrun.lua': No such file or directory
cp: cannot stat '/usr/local/lmtx/tex/texmf-context/scripts/context/lua/mtx-install.lua': No such file or directory

If you want to run ConTeXt everywhere, you need to adapt the path, like:

  export PATH=/usr/local/lmtx/tex/texmf-linux/bin:/usr/local/lmtx/bin:/usr/local/lmtx/tex/texmf-linux/bin:/root/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/qt/bin:/usr/local/rvm/bin:/usr/share/texmf/bin:/net/sw/bin

If you run from an editor you can specify the full path to mtxrun:

  /usr/local/lmtx/tex/texmf-linux/bin/mtxrun --autogenerate --script context --autopdf ...

The following settings were used:

  server   : lmtx.contextgarden.net,lmtx.pragma-ade.com,lmtx.pragma-ade.nl
  instance : install-lmtx
  extras   :
  ownpath  : /usr/local/lmtx
  platform : linux
------------------------------------------------------------------------

And here's what ldd reports:

------------------------------------------------------------------------
# ldd -v bin/mtxrun
bin/mtxrun: /lib/libm.so.6: version `GLIBC_2.23' not found (required by bin/mtxrun)
        linux-gate.so.1 (0xffffe000)
        libm.so.6 => /lib/libm.so.6 (0xb71bf000)
        libdl.so.2 => /lib/libdl.so.2 (0xb71ba000)
        libc.so.6 => /lib/libc.so.6 (0xb702e000)
        /lib/ld-linux.so.2 (0xb778d000)

        Version information:
        bin/mtxrun:
                libdl.so.2 (GLIBC_2.1) => /lib/libdl.so.2
                libdl.so.2 (GLIBC_2.0) => /lib/libdl.so.2
                libc.so.6 (GLIBC_2.15) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.4) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.3) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.7) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.17) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.11) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
                libm.so.6 (GLIBC_2.23) => not found
                libm.so.6 (GLIBC_2.1) => /lib/libm.so.6
                libm.so.6 (GLIBC_2.0) => /lib/libm.so.6
        /lib/libm.so.6:
                ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
                libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
                libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
        /lib/libdl.so.2:
                ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
                libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
        /lib/libc.so.6:
                ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
                ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
                ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2
------------------------------------------------------------------------

I don't think I can upgrade glibc, however -- I'm stuck on Slackware 
14.1 for now.

Oh well, it's no big deal for me.

Paul.

-- 
Paul Hoffman <nkuitse at nkuitse.com>


More information about the ntg-context mailing list