[NTG-context] em-dash ligature is converted to en-dash in the generic fontloader

Hans Hagen j.hagen at xs4all.nl
Fri Mar 1 11:17:56 CET 2019


On 2/28/2019 12:38 PM, Marcel Kr├╝ger wrote:
> On 2/23/2019 1:50 PM, Ulrike Fischer wrote:
>> As reported on the dev-luatex list --- is converted to an en-dash
>> (instead of em-dash) if there are no spaces around the ---.
>>
>> We could now reproduce the problem also with the generic fontloader:
>> it appears only with mode=node. I'm using the files from 2019-02-14,
>> but the problem appeared first in the files from 2018-11-18):
>>
>> \font\test={file:texgyreheros-regular.otf:+tlig;mode=node;}\test
>>
>> dashes-these % gives dash
>>
>> dashes--these % gives en-dash
>>
>> dashes---these % gives en-dash WRONG
>>
>> dashes --- these % gives em-dash
>>
>> em-dashes---these % gives em-dash
>>
>> \bye
>>
>> context is not affected, there the code works fine.
> 
> This issue can be fixed in the fontloader with the attached patch.
Hm, I don't see those lines here and it looks ok in context so ... no 
patches applied (and definitely not in the tex live code freeze window)

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list