[NTG-context] Problem with grid alignment and paragraph

Luca Donetti donetti at gmail.com
Sat Jan 19 19:35:19 CET 2019


On Mon, Jan 7, 2019 at 9:35 PM Wolfgang Schuster <
wolfgang.schuster.lists at gmail.com> wrote:

> Luca Donetti schrieb am 07.01.19 um 21:21:
> > On Sun, Jan 6, 2019 at 2:53 PM Wolfgang Schuster
> > <wolfgang.schuster.lists at gmail.com
> > <mailto:wolfgang.schuster.lists at gmail.com>> wrote:
> >
> >     Luca Donetti schrieb am 14.12.18 um 22:14:
> >     > Dear list,
> >     >
> >     > I am facing a problem with grid alignment when using paragraphs. I
> >     > think it could be a bug because the MWE below produces lines
> >     which are
> >     > correctly aligned to the grid with the context version included in
> >     > texlive 2017, but it does not seem to work with the context in
> >     texlive
> >     > 2018 and the current beta (ConTeXt  ver: 2018.12.07 19:37 MKIV beta
> >     > fmt: 2018.12.14).
> >     > This is the MWE:
> >     >
> >     > \setuplayout[grid=yes]
> >     > \defineparagraphs[twocols][n=2]
> >     > \showgrid
> >     >
> >     > \starttext
> >     > \starttwocols
> >     > \input knuth
> >     > \nexttwocols
> >     >   \input knuth
> >     > \stoptwocols
> >     > \stoptext
> >     >
> >     > Am I doing anything wrong? If not, I'll appreciate any
> >     suggestion or
> >     > workaround.
> >
> >
> https://tex.stackexchange.com/questions/468711/context-defineparagraphs-aligned-to-grid/
> >
> >     Wolfgang
> >
> > Dear Wolfgang,
> >
> > thank you for your help. Unfortunately, if I follow the suggestion in
> > your link (using [location=depth]), the alignment improves but it is
> > still not good: some lines are on grid while some others are not. If I
> > understand correctly your answer, inside the \framed there is a table
> > and, in this case, it seems to me that the spacing between lines is
> > not always equal to the grid spacing.
> >
> > Is there a way to force the interline spacing inside the \framed
> > block? I'm sorry if this is a simple question, but I'm quite new to
> > context.
>
> The interlinespace is correct but the paragraphs environment is too high,
> location=bottom puts the text on the baseline but it adds an extra blank
> line at the begin of the environment.
>
> A simple fix to get rid of the extra line is to set the width of the frame
> border to 0pt which doesn’t matter when the rules are disabled.
>
> \setuplayout[grid=yes]
>
> \defineparagraphs [twocols] [n=2]
>
> \setupparagraphs
>    [twocols]
>    [location=bottom,
>     rulethickness=0pt]
>
> \showgrid
>
> \starttext
>
> \starttwocols
>    \input knuth
>    \nexttwocols
>    \input knuth
> \stoptwocols
>
> \stoptext
>
> Wolfgang
>

 Dear Wolfgang,

thank you very much for your reply (and sorry for my late reply). Your
suggestion do solve my minimal example but, unfortunately, not my real
world example. I will try to find another minimal example which still shows
the problem. In the meantime I'll try to play with different options of
location=.

LD
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20190119/790740eb/attachment.html>


More information about the ntg-context mailing list