[NTG-context] TextMate ConTeXt bundle

Manuel Blanco manuelbl at ucm.es
Wed Nov 14 11:12:00 CET 2018


Hi all,

After some years with LaTeX and let's say three or four times trying
to start with ConTeXt, I decided to try again. Difficult, there are
many manuals and a lot of contradicting ideas (at least for those of
us that do not know) in them, but still, I want to try to see if once
and for all I can manage to dominate it.

I have installed MacTeX 2018. I use TextMate, and the ConTeXt bundle
is not working in Mac OS High Sierra. After installing it, when I
tried to compile it said something along the lines "your PATH is ...
you should have 'context' in your path", so I searched in my computer
and changed TextMate PATH to:

    $PATH:/opt/local/bin:/usr/local/bin:/usr/texbin:/usr/local/texlive/2018/texmf-dist/scripts/context/stubs/unix

And this last part is where I think the context binary seems to be
/usr/local/texlive/2018/texmf-dist/scripts/context/stubs/unix

But now when I run it it says

    env: texlua: No such file or directory

What could be happening? What do I do?

Also, the bundle was last updated in 2010, may be there are new
things? Where could we learn what things to add?

https://github.com/pgundlach/context.tmbundle

Any updated documentation that takes you from beginner to intermediate
would be apreciated too.

Thanks,
Manuel


More information about the ntg-context mailing list