[NTG-context] Problem installing a new font

Procházka Lukáš Ing. LPr at pontex.cz
Sat Nov 10 21:56:13 CET 2018


Hello,

probably one of the basic questions and skills in ConTeXt, but the first case for me: how to install a (downloaded third-party) font into ConTeXt:

I downloaded font source files from https://www.ctan.org/tex-archive/fonts/aurical/ and I unpacked the .zip content, so I have now (see FileList.txt for full info):

----
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\afm
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\FileList.txt
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\map
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\tfm
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\type1
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\afm\public
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\afm\public\aurical
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\afm\public\aurical\AmiciLogo.afm
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\afm\public\aurical\AmiciLogoBold.afm
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\afm\public\aurical\AmiciLogoBoldRslant.afm
...
d:\Lukas\ConTeXt\Fonts\Aurical\fonts\type1\public\aurical\LukasSvatbaSlant.pfb
----

Trying to install the font the easiest way, I also copied files into my ConTeXt dir, so I have also (see FileList2.txt):

----
d:\Ctx-Beta\tex\texmf\fonts\afm\public\aurical\AmiciLogo.afm
d:\Ctx-Beta\tex\texmf\fonts\afm\public\aurical\AmiciLogoBold.afm
d:\Ctx-Beta\tex\texmf\fonts\afm\public\aurical\AmiciLogoBoldRslant.afm
d:\Ctx-Beta\tex\texmf\fonts\afm\public\aurical\AmiciLogoBoldSlant.afm
...
d:\Ctx-Beta\tex\texmf\fonts\type1\public\aurical\AmiciLogo.pfb
d:\Ctx-Beta\tex\texmf\fonts\type1\public\aurical\AmiciLogoBold.pfb
d:\Ctx-Beta\tex\texmf\fonts\type1\public\aurical\AmiciLogoBoldRslant.pfb
d:\Ctx-Beta\tex\texmf\fonts\type1\public\aurical\AmiciLogoBoldSlant.pfb
...
----

I tried to follow instructions in 'mfonts.pdf' mentioned at https://wiki.contextgarden.net/Fonts, but early I failed with (unknown) "texfont" command cited here frequently.

I also experimented somehow with "mtxrun --make --generate" and "mtxrun script --font --reload --force" and with a simple show-font file which starts with:

----
\definefont[FONT][AmiciLogo.afm]
...
----

but the result is not written by AmiciLogo font.

So - how to make ConTeXt aware of a third-party font and how to use the font in the document?

Best regards,

Lukas


-- 
Ing. Lukáš Procházka | mailto:LPr at pontex.cz
Pontex s. r. o.      | mailto:pontex at pontex.cz | http://www.pontex.cz | IDDS:nrpt3sn
Bezová 1658
147 14 Praha 4

Mob.: +420 702 033 396
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: FileList.txt
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20181110/2aacb544/attachment-0002.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: FileList2.txt
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20181110/2aacb544/attachment-0003.txt>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: HW.mkiv
Type: application/octet-stream
Size: 727 bytes
Desc: not available
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20181110/2aacb544/attachment-0001.obj>


More information about the ntg-context mailing list