[NTG-context] \startregister…\stopregister bug?

Wolfgang Schuster wolfgang.schuster.lists at gmail.com
Tue Aug 14 17:31:33 CEST 2018


You forgot the second argument for \startregister and \stopregister.


\defineregister[TesT]

\starttext

\startregister[TesT][one]{samples}

\input knuth

\page

\startregister[TesT][two]{more}

\input ward

\stopregister[TesT][one]

\page zapf

\stopregister[TesT][two]

\blank[3*big]

\placeregister[TesT]

\stoptext


Wolfgang

Alan Bowen schrieb am 14.08.18 um 17:25:
> In the latest beta (2018.08.10),
>
> \defineregister[TesT]
> \starttext
> \startregister[TesT]{samples}
> \input knuth
> \page
> \input ward
> \stopregister[TesT]
> \blank[3*big]
> \placeregister[TesT]
> \stoptext
>
> produces on page 2 the index entry
> /samples 1/
> when one expects
> /samples 1–2/
> /
> /
> Alan
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
>
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
> archive  : https://bitbucket.org/phg/context-mirror/commits/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20180814/b734e5d5/attachment.html>


More information about the ntg-context mailing list