[NTG-context] issues with \comment

Pablo Rodriguez oinos at gmx.es
Fri Jul 6 11:14:50 CEST 2018


Dear list,

I have the following sample:

    \setupinteraction[state=start]
    \setupcomment[location=inmargin, color=darkred]
    \showframe
    \startbuffer[abc]
    \input zapf
    \stopbuffer
    \setuptype[option=tex]
    \starttext
    \comment[space=yes,buffer=abc]{}
    \type{\comment[space=yes,buffer=abc]{}}
    \blank[2*big]

    \comment[location=leftmargin,space=yes,buffer=abc]{}
    \type{\comment[location=leftmargin,space=yes,buffer=abc]{}}
    \blank[2*big]

    \comment[location=rightmargin,space=yes,buffer=abc]{}
    \type{\comment[location=rightmargin,space=yes,buffer=abc]{}}
    \blank[2*big]

    \comment[location=inmargin,space=yes,buffer=abc]{}
    \type{\comment[location=inmargin,space=yes,buffer=abc]{}}
    \blank[2*big]

    \comment[location=leftedge,space=yes,buffer=abc]{}
    \type{\comment[location=leftedge,space=yes,buffer=abc]{}}
    \blank[2*big]

    \type{\comment[location=rightedge,space=yes,buffer=abc]{}}
    \blank[2*big]

    \comment[location=text,space=yes,buffer=abc]{}
    \type{\comment[location=text,space=yes,buffer=abc]{}}
    \blank[2*big]

    \comment[space=yes,buffer=abc]{}
    \type{\comment[space=yes,buffer=abc]{}}
    \blank[2*big]

    \comment[location=high,space=yes,buffer=abc]{}
    \type{\comment[location=high,space=yes,buffer=abc]{}}
    \blank[2*big]
    \stoptext

I’m afraid buffer contents aren’t expanded in \comment.

Locations for leftedge, rightedge and text don’t seem to work (in
Acrobat Reader, SumatraPDF and Evince).

Default value for location seems to depend on the value of last comment
(even if a default value has been set in \setupcomment).

Am I missing something or have I hit a bug?

Many thanks for your replies,

Pablo
-- 
http://www.ousia.tk


More information about the ntg-context mailing list