[NTG-context] mtxrun fails to install fonts

Hans Hagen j.hagen at xs4all.nl
Wed Jul 4 09:32:59 CEST 2018


On 7/3/2018 6:50 PM, Stanislav Sokolenko wrote:
> Dear list,
> 
> I have what seems to be an OS- or ConTeXt version-specific issue with 
> mtxrun installing fonts.
> 
> I've been trying to add new truetype fonts (specifically Archivo ttf 
> files) on Arch Linux using the following command:
> 
> export OSFONTDIR=~/.fonts//; mtxrun --script font --reload
> 
> And I've been using the following to check the installation:
> 
> mtxrun --script font --list --all --pattern=*archi*
> 
> It seems like a relatively new version of ConTeXt on Arch Linux 
> (2018.04.04 00:51) recognizes but does not install the ttf files located 
> in ~/.fonts/. The (shortened) output is:
> 
> fonts           | names | identifying system font files with suffix 'ttf'
> fonts           | names | globbing path '/home/stanislav/.fonts/**.ttf'
> fonts           | names | identifying system font files with suffix 'TTF'
> fonts           | names | globbing path '/home/stanislav/.fonts/**.TTF'
> fonts           | names | 8 system files identified, 0 skipped, 0 
> duplicates, 8 hash entries added, runtime 0.006 seconds
> 
> But when I check the installation, no Archivo files are found.
> 
> Strangely, an older installation on Linux Mint (2015.05.18 12:26) has no 
> problems with the same ttf files:
> 
> fonts           | names | globbing path '/home/stanislav/.fonts/**.ttf'
> fonts           | names | identifying system font files with suffix 'TTF'
> fonts           | names | globbing path '/home/stanislav/.fonts/**.TTF'
> fonts           | names | 8 system files identified, 0 skipped, 0 
> duplicates, 8 hash entries added, runtime 0.000 seconds
> 
> And the check:
> 
> mtxrun --script font --list --all --pattern=*archi*
> 
> archivo                 archivomedium 
> /home/stanislav/.fonts/typecatcher/Archivo_500.ttf
> archivobold             archivobold 
> /home/stanislav/.fonts/typecatcher/Archivo_700.ttf
> archivobolditalic       archivobolditalic 
> /home/stanislav/.fonts/typecatcher/Archivo_700italic.ttf
> archivodemi             archivosemibold 
> /home/stanislav/.fonts/typecatcher/Archivo_600.ttf
> archivoitalic           archivoitalic 
> /home/stanislav/.fonts/typecatcher/Archivo_italic.ttf
> archivomedium           archivomedium 
> /home/stanislav/.fonts/typecatcher/Archivo_500.ttf
> archivomediumitalic     archivomediumitalic 
> /home/stanislav/.fonts/typecatcher/Archivo_500italic.ttf
> archivonormal           archivoitalic 
> /home/stanislav/.fonts/typecatcher/Archivo_italic.ttf
> archivoregular          archivoregular 
> /home/stanislav/.fonts/typecatcher/Archivo_regular.ttf
> archivosemibold         archivosemibold 
> /home/stanislav/.fonts/typecatcher/Archivo_600.ttf
> archivosemibolditalic   archivosemibolditalic 
> /home/stanislav/.fonts/typecatcher/Archivo_600italic.ttf
> 
> I've been searching for a couple of days and I'm at a loss. Is there a 
> way to check why the identified system files aren't being installed?
Can you test the beta from the contextgarden?

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list