[NTG-context] Bug with \setuptagging and layers

Hans Hagen j.hagen at xs4all.nl
Sun Jun 10 13:40:41 CEST 2018


On 6/10/2018 12:05 AM, Rik Kabel wrote:
> When the first line of the following example is removed, all is well. 
> With it present, the image in the layer has the text "image" added to 
> the image. This problem is not present in, inter alia, TL18.
> 
>     \setuptagging         [state=start]
>     \setupexternalfigures [location=default]
>     \definelayout         [testpage]
>     \definelayer          [testpage]
>     [width=\paperwidth,height=\paperheight]
>     \startsetups          [testpage]
>          \setlayerframed   [testpage]
>     [preset=rightbottom,hoffset=.25in,voffset=.25in,
>     background=color,backgroundcolor=yellow]
>                            {\externalfigure[cow.pdf]}
>     \stopsetups
>     \setupbackgrounds     [page]
>     [setups=testpage,background={testpage}]
>     \starttext
>     \startmakeup          [testpage]
>     \framed[background=color,backgroundcolor=yellow]
>                                   {\externalfigure[cow.pdf]}
>     \stopmakeup
>     \stoptext
line 287 in strc-tag:

\let\strc_tags_start_nop_ignore\gobbletwoarguments

fixed in next beta

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list