[NTG-context] Strange behaviour of \start/stopplacefigure

Hans Hagen j.hagen at xs4all.nl
Tue Apr 3 10:13:55 CEST 2018


On 4/3/2018 12:38 AM, Aditya Mahajan wrote:
> On Mon, 2 Apr 2018, Wolfgang Schuster wrote:
> 
>> The problem is that float with the “bottom” or “auto” positions don’t 
>> indent the paragraph
>> which appears after the float while “top” does it.
>>
>>
>> %%%% begin example
>> \setupindenting[yes,6cm]
>> \setupfloat[figure][indentnext=yes]
>>
>> \starttext
>>
>> \setupbodyfont[modern]
>>
>> {\bf NONE:} \input lorem
>>
>> \placefigure[here]{HERE}{\blackrule[width=6cm,height=2cm]}
>>
>> {\bf HERE:} \input lorem
>>
>> \placefigure[top]{TOP}{\blackrule[width=6cm,height=2cm]}
>>
>> {\bf TOP:} \input lorem
>>
>> \placefigure[bottom]{BOTTOM}{\blackrule[width=6cm,height=2cm]}
>>
>> {\bf BOTTOM:} \input lorem
>>
>> \placefigure[auto]{AUTO}{\blackrule[width=6cm,height=2cm]}
>>
>> {\bf AUTO:} \input lorem
>>
>> \stoptext
>> %%%% end example
>>
>>
>> The reason for this are these line in page-one.mkiv:
>>
>> \def\page_one_place_float_auto       {\page_one_place_float_otherwise}
>> \def\page_one_place_float_top 
>> {\page_one_place_float_otherwise\nonoindentation}
>> \def\page_one_place_float_bottom     {\page_one_place_float_otherwise}
> 
> Older discussion on the same topic:
> 
> https://www.mail-archive.com/ntg-context@ntg.nl/msg83098.html

the question is: do we accept an incompatibility when we do that


-- 

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list