[NTG-context] Problem with setuptagging and ebgaramond font

Hans Hagen pragma at wxs.nl
Mon Nov 21 11:59:32 CET 2016


On 11/21/2016 2:54 AM, Rik Kabel wrote:
> On 2016-11-20 13:37, Hans Hagen wrote:
>> On 11/20/2016 6:17 PM, Rik Kabel wrote:
>>> I still do not understand why \setuptagging[state=start] made a
>>> difference. Something there is hinky[1].
>>>
>>> [1] Someone, or something, may be said to be hinky if it acts in a
>>> manner that arouses suspicion. The origin is obscure.
>>
>> hard to comment when i cannot reproduce it
>
> The problem can be reproduced on my Windows 10 system by removing
> existing EBGaramond12 and installing EBGaramond12 from version 0.015d,
> followed by a cache clear. It is available on Georg Duffner's bitbucket
> at https://bitbucket.org/georgd/eb-garamond/downloads. The problem I had
> before was ensuring that the old versions of the font files were
> actually removed -- I found versions with _0 and _1 suffixes that did
> not show up in explorer and were not removable by an administrator in a
> command prompt terminal. Other tools allowed their removal.

the softhyphen in ebgaramond has zero width and no visualization .. i 
can patch that in the font (when loading) but can also consider it a bug 
in the font

(i'll make it configurable in tagging but that only obscures the issue)

Hans


-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
        tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list