[NTG-context] two questions on xml handling

Pablo Rodriguez oinos at gmx.es
Sat Oct 22 19:48:30 CEST 2016


Dear list,

I have two questions about the following sample:

     \startbuffer[demo]
        <doc>Two links: <a>Document 1</a>, <em><a>Document 2</a></em>.
        And <em><em>different</em></em> results.</doc>
    \stopbuffer

    \startxmlsetups xml:initialize
        \xmlsetsetup{#1}{*}{-}
        \xmlsetsetup{#1}{doc|em}{xml:*}
        %~ \xmlsetsetup{#1}{(a|em/a)}{xml:linked}
        %~ \xmlsetsetup{#1}{(a or em/a)}{xml:linked}
        \xmlsetsetup{#1}{a}{xml:linked}
        \xmlsetsetup{#1}{em/a}{xml:linked}
    \stopxmlsetups

    \xmlregistersetup{xml:initialize}

    \startxmlsetups xml:doc
        \xmlflush{#1}
    \stopxmlsetups

    \startxmlsetups xml:em
        \bgroup\em\xmlflush{#1}\egroup
    \stopxmlsetups

    \startxmlsetups xml:linked
        \bgroup\em\xmlflush{#1}\egroup
    \stopxmlsetups

    \starttext
         \xmlprocessbuffer{main}{demo}{}
    \stoptext

The first issue is why doesn’t the lpaths with "or" and "|" don’t work.
Or at least, they give a different result from defining each lpath
separately.

The second issue is why the lpath em/a gets double emphasis. Since I
seem to be missing something, which is the way to avoid that the em/a
lpath doesn’t get the em lpath applied? (I mean, that "Document 2" only
gets an emphasis.)

Many thanks for your help,

Pablo
-- 
http://www.ousia.tk


More information about the ntg-context mailing list