[NTG-context] insert pagebreak in toc (MkIV)

Robert Blackstone blackstone.robert at gmail.com
Tue Sep 6 10:26:42 CEST 2016


On 6 Sep 2016, at 09:06 ,  Robert Blackstone <blackstone.robert at gmail.com>
> To: ntg-context at ntg.nl
> 
> On 5 Sep 2016, at 11:06 ,  Hans Hagen <pragma at wxs.nl> wrote
>> 
>> On 9/5/2016 9:06 AM, Robert Blackstone wrote:
>>> 
>>> I need a pagebreak in the ToC to avoid a widow.
>>> So far I used the method given in sept 2010 in https://mailman.ntg.nl/pipermail/ntg-context/2010/052739.html, and
>>> still on http://wiki.contextgarden.net/Table_of_Contents#Forced_Page_Break,  but
>>> it does not seem to work anymore.
>>> 
>>> MWE (from the first-mentioned site):
>>> %%%%%%%%%%%%%%%
>>> 
>>> \definelistextra[page][before=\page,after=\page]
>>> 
>>> \starttext
>>> 
>>>    \placelist[chapter,section][criterium=text,extras={1.1=page}]
>>> 
>>>    \chapter{x1}
>>>    \section{xx1}
>>>    \section{xx2}
>>>    \chapter{y2}
>>>    \section{yy1}
>>>    \section{yy2}
>>> 
>>> \stoptext
>>> 
>>> %%%%%%%%%%%%%%%%%
>>> Compiled with a recent mkiv, from between sept 2015 till july 2016, the
>>> result shows no page break in the ToC.
>>> What can be done about this?
>> 
>> \showinjector
>> 
>> \setinjector[register][3][\column]
>> \setinjector[list]    [2][{\blank[3*big]}]
>> 
>> \starttext
>>    \placelist[section][criterium=text]
>>    \blank[3*big]
>>    \placeregister[index][criterium=text]
>>    \page
>>    \startsection[title=Alpha] first  \index{first}  \stopsection
>>    \startsection[title=Beta]  second \index{second} \stopsection
>>    \startsection[title=Gamma] third  \index{third}  \stopsection
>>    \startsection[title=Delta] fourth \index{fourth} \stopsection
>> \stoptext
> 
> Thanks Hans, for your quick reaction.
> 
> Maybe my question was not clear enough but in any case your remedy does not help me.
> .. etc.

Dear Hans, 
My apologies. Your remedy does help. Initially I just didn’t understand what to do with this injector.

Best regards,
Robert Blackstone


> 
> 
> 
> 
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Mon, 5 Sep 2016 16:33:53 +0200
> From: Pablo Rodriguez <oinos at gmx.es>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: Re: [NTG-context] bug in latest beta?
> Message-ID: <58e9fb16-dade-5cb0-3c0c-c2cc572d9e6b at gmx.es>
> Content-Type: text/plain; charset=utf-8
> 
> On 09/05/2016 10:39 AM, Akira Kakuto wrote:
>>> the following sample gives a Lua error with latest beta (2016.09.04 13:46):
>> 
>> Compilation is fine in the latest luatex 0.98.4 with
>> mtx-context     | current version: 2016.09.04 13:46.
>> 
> 
> Hi Akira,
> 
> it seems that luatex-0.98.4 has been released for Windows today.
> 
> I will wait for the release in the Linux 32bit platform.
> 
> Luigi, would it be possible that all platforms have the latest LuaTeX
> version included?
> 
> Many thanks for your help,
> 
> 
> Pablo
> -- 
> http://www.ousia.tk
> 
> 
> ------------------------------
> 
> Message: 3
> Date: Mon, 5 Sep 2016 16:44:16 +0200
> From: luigi scarso <luigi.scarso at gmail.com>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: Re: [NTG-context] bug in latest beta?
> Message-ID:
> 	<CAG5iGsAuy8=DrGFP6YM37ungYB_xrYs76ydu2aSx74W1HXBUZA at mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
> 
> On Mon, Sep 5, 2016 at 4:33 PM, Pablo Rodriguez <oinos at gmx.es> wrote:
>> On 09/05/2016 10:39 AM, Akira Kakuto wrote:
>>>> the following sample gives a Lua error with latest beta (2016.09.04 13:46):
>>> 
>>> Compilation is fine in the latest luatex 0.98.4 with
>>> mtx-context     | current version: 2016.09.04 13:46.
>>> 
>> 
>> Hi Akira,
>> 
>> it seems that luatex-0.98.4 has been released for Windows today.
>> 
>> I will wait for the release in the Linux 32bit platform.
>> 
>> Luigi, would it be possible that all platforms have the latest LuaTeX
>> version included?
> 
> experimental is, well, experimental, so not trunk and not even a tag
> (i.e. a new version).
> But you can easily compile it from svn, it's a matter of
> ./build.sh --parallel --jit
> 
> 
> -- 
> luigi
> 
> 
> ------------------------------
> 
> Message: 4
> Date: Mon, 5 Sep 2016 17:10:51 +0200
> From: Pablo Rodriguez <oinos at gmx.es>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: Re: [NTG-context] bug in latest beta?
> Message-ID: <2aaaf0cb-153a-8a12-e49c-78856eda2dbc at gmx.es>
> Content-Type: text/plain; charset=utf-8
> 
> On 09/05/2016 08:36 AM, josephcanedo at gmail.com wrote:
>> Dear all,
>> 
>> Sounds like  a typo in file
>> tex/texmf-context/tex/context/base/mkiv/node-nut.lua line 238
>> 
>> find_tail should be findtail I think.
> 
> Hi Joseph,
> 
> sorry for overlooking your message.
> 
> Of course, you are right. (I cannot code, but defining a local variable
> in line 233 and using it with an underscore in line 238 doesn’t make
> sense even to me.)
> 
> I’m afraid that the typo is present in the newer beta from today
> (2016.09.05 10:28).
> 
> Many thanks for your help,
> 
> 
> Pablo
> -- 
> http://www.ousia.tk
> 
> 
> ------------------------------
> 
> Message: 5
> Date: Mon, 5 Sep 2016 17:32:08 +0200
> From: Pablo Rodriguez <oinos at gmx.es>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: Re: [NTG-context] bug in latest beta?
> Message-ID: <adea72e3-383f-1318-4411-73970f92201a at gmx.es>
> Content-Type: text/plain; charset=utf-8
> 
> On 09/05/2016 04:44 PM, luigi scarso wrote:
>> On Mon, Sep 5, 2016 at 4:33 PM, Pablo Rodriguez wrote:
>>> [...]
>>> Luigi, would it be possible that all platforms have the latest LuaTeX
>>> version included?
>> 
>> experimental is, well, experimental, so not trunk and not even a tag
>> (i.e. a new version).
>> But you can easily compile it from svn, it's a matter of
>> ./build.sh --parallel --jit
> 
> Sorry for the noise, Luigi.
> 
> I have corrected the variable (as described in
> https://mailman.ntg.nl/pipermail/ntg-context/2016/086761.html) and it
> works fine.
> 
> Many thanks for your help,
> 
> Pablo
> -- 
> http://www.ousia.tk
> 
> 
> ------------------------------
> 
> Message: 6
> Date: Mon, 5 Sep 2016 20:55:58 -0400 (EDT)
> From: Aditya Mahajan <adityam at umich.edu>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: Re: [NTG-context] Enumeration: chapter in counter, problem
> 	next to placefigure, and documentation issues
> Message-ID: <alpine.OSX.2.02.1609052054170.4342 at nqv-znpobbx>
> Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed
> 
> On Mon, 5 Sep 2016, Florian Leupold wrote:
> 
>> One problem, however, persists: The theorem environment gets misplaced 
>> when a figure is placed to its left:
>> 
>> \setupexternalfigures[location=default]
>> \setupenumerations[
>> 	alternative=left,
>> 	text=Theorem,
>> 	title=no,
>> 	stopper={:},
>> 	distance=0ex,
>> 	width=fit,
>> 	right={~},
>> 	style=normal,
>> 	hang=fit]
> 
> I am not sure what visual layout you want, but how about using:
> 
> \setupenumerations[
>         alternative=serried,
>         text=Theorem,
>         title=no,
>         stopper={:},
>         distance=0ex,
>         width=fit,
>         right={~},
>         style=normal,
>       ]
> \defineenumeration[theorem]
> 
> Aditya
> 
> 
> 
> ------------------------------
> 
> Message: 7
> Date: Tue, 6 Sep 2016 06:43:28 +0200
> From: Pablo Rodriguez <oinos at gmx.es>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: Re: [NTG-context] bug in latest beta?
> Message-ID: <992d5527-6fa2-53ee-1905-886447ff5ea1 at gmx.es>
> Content-Type: text/plain; charset=utf-8
> 
> On 09/05/2016 05:10 PM, Pablo Rodriguez wrote:
>> [...]
>> I’m afraid that the typo is present in the newer beta from today
>> (2016.09.05 10:28).
> 
> The issue has been fixed in latest beta (2016.09.06 00:28).
> 
> Hans, many thanks for the fix.
> 
> 
> Pablo
> -- 
> http://www.ousia.tk
> 
> 
> ------------------------------
> 
> Message: 8
> Date: Tue, 6 Sep 2016 09:05:47 +0200
> From: Henri Menke <henrimenke at gmail.com>
> To: mailing list for ConTeXt users <ntg-context at ntg.nl>
> Subject: Re: [NTG-context] Perhaps missing braces in buff-ini.mkiv?
> Message-ID: <b171a15c-2e4b-0372-7c92-9a37370a0de1 at gmail.com>
> Content-Type: text/plain; charset=utf-8
> 
> Bump
> 
> On 08/09/2016 10:54 AM, Henri Menke wrote:
>> Dear list,
>> 
>> it seems as if there are braces missing in the definition of \buff_save around #2.
>> 
>> \def\buff_save[#1][#2]%
>>  {...
>>    {\setupcurrentsavebuffer[\c!list={#1},\c!file=#2]}%
>>  ...}
>> 
>> I think they are missing, because it makes the following work, even though arguments and key-value arguments shouldn't be mixed up.
>> 
>> \startbuffer[hash]
>> foo
>> \stopbuffer
>> \savebuffer[hash][hello.txt,prefix=no]
>> \starttext
>> \stoptext
>> 
>> I think you should either make a third argument for a key-value list or just make the second argument the key-value list.  Then users could input \savebuffer[hash][file=hello.txt,prefix=no].
>> 
>> Cheers, Henri
>> 
> 
> 
> 
> ------------------------------
> 
> Subject: Digest Footer
> 
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
> 
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : https://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________
> 
> ------------------------------
> 
> End of ntg-context Digest, Vol 147, Issue 12
> ********************************************



More information about the ntg-context mailing list