[NTG-context] Problems with old style figures and particular font

Wolfgang Schuster schuster.wolfgang at gmail.com
Thu Aug 11 08:43:32 CEST 2016


> Martin Oppegaard <mailto:martin.oppegaard at gmail.com>
> 10. August 2016 um 22:27
> Dear list,
>
> I'm having problems getting old style figures and ligatures with the fbb
> font. I'm using Tex live 2014 on OpenBSD 5.9 and context version
> 2014.05.21 22:04. otfinfo -f fbb-Regular.otf reports that it has onum
> and liga, and it works fine with lualatex. I have tried with a
> typescript and simplefont (the fbb font is being used in all three
> cases); see attached examples. Do you have any suggestions?
>
> % type-fbb.mkiv
> \starttypescript [serif] [fbb] [name]
> \definefontsynonym [Serif] [file:fbb-Regular.otf] [features=default]
> \definefontsynonym [SerifItalic] [file:fbb-Italic.otf] [features=default]
> \stoptypescript
>
> \starttypescript [fbb]
> \definetypeface [fbb] [rm] [serif] [fbb] [default]
> \stoptypescript
>
>
> % contex-test1.tex
> \usetypescriptfile[type-fbb]
> \usetypescript[fbb]
> \setupbodyfont[fbb,11pt]
> \definefontfeature[default][default][liga=yes,onum=yes]
Move the \definefontfeature setting before \setupbodyfont because 
changes to the feature set after the font is loaded are ignored.

\definefontfeature[default][default][liga=yes,onum=yes]
\setupbodyfont[fbb,11pt]

Wolfgang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20160811/dd5d3d45/attachment-0001.html>


More information about the ntg-context mailing list