[NTG-context] Error in loading font Samim

Mohammad Hossein Bateni bateni at gmail.com
Mon Aug 8 04:24:41 CEST 2016


Please ignore my last message.  It seems to be working fine now.  Probably
a bad setup on my part.  I will ping again if I run into the same issue
again.

On Sun, Aug 7, 2016 at 10:12 PM, Mohammad Hossein Bateni <bateni at gmail.com>
wrote:

> Hello,
>
> I believe this worked fine in June's beta but now gives an error.
>
>
> \starttext
> \definedfont[Samim]
> سلام
> \stoptext
>
>
> I got the font originally from here
> <https://github.com/rastikerdar/samim-font/releases/download/v0.11.0/samim-font-v0.11.0.zip>,
> but then removed the MATH table because it was causing an error at the time
> to get the attached version.
>
> Now the above code gives the following error:
>
>
> ...ntext/tex/texmf-context/tex/context/base/mkiv/l-lpeg.lua:290: bad
> argument #2 to '__div' (invalid replacement value)
> stack traceback:
> [C]: in function '__div'
> ...ntext/tex/texmf-context/tex/context/base/mkiv/l-lpeg.lua:290: in
> function 'splitter'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-otc.lua:159: in
> function 'addfeature'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-otc.lua:730: in
> function 'enhancer'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-con.lua:1269: in
> function 'enhance'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-con.lua:1291: in
> function 'apply'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-otl.lua:246: in
> function 'load'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-otl.lua:538: in
> function 'otftotfm'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-otl.lua:566: in
> function <...ext/tex/texmf-context/tex/context/base/mkiv/font-otl.lua:565>
> (...tail calls...)
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-def.lua:304: in
> function 'loadfont'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-ctx.lua:492: in
> function 'loadfont'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-def.lua:418: in
> function 'read'
> ...ext/tex/texmf-context/tex/context/base/mkiv/font-ctx.lua:1172: in
> function <...ext/tex/texmf-context/tex/context/base/mkiv/font-ctx.
> lua:1059>
>
>
> Could you advise me on how to get over this issue?  As far as I know, the
> font lacks Latin characters and is restricted to the Arabic/Farsi
> characters.  In a more complicated example, I used dejavusans as fallback
> but the above MWE seemed fine, as far as I remember.
>
> Thanks,
> MHB
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20160807/51700e69/attachment.html>


More information about the ntg-context mailing list