[NTG-context] ConTeXt and LilyPond problem

Robert Blackstone blackstone.robert at gmail.com
Wed Jun 29 10:47:22 CEST 2016


On 28 Jun 2016, at 14:16 , Mojca Miklavec <mojca.miklavec.lists at gmail.com> wrote
>> 
>> On 27 June 2016 at 16:11, Robert Blackstone wrote:
>>> Dear All,
>>> 
>>> I am trying to get the combination of ConTeXt and LilyPond working.
>>> I copied the example that I found on http://wiki.contextgarden.net/LilyPond
>>> , changing the setups a little (I don't have the font  Adobe Jenson Pro).
>>> 
>>> Processing it with mkiv from april this year and earlier produces a pdf with
>>> both zapf texts and in between the text: [[output file missing.
>>> 
>> 
>> You first need to get lilypond working from Terminal, otherwise asking
>> any other question on the ConTeXt mailing list won't really help much.
>> 
>> 
>> Mojca
> 
> Thanks Mojca,
> 
> I have tried to get lilypond working from Terminal but without success. No idea why. Whatever I do Terminal replies with : cannot execute binary file.

Dear all, and in particular Mojca Miklavec and Jean-Pierre Delange, who reacted to my first call for help, 

I think I have solved my problem.
Somehow I managed to get Lilypond working from Terminal.  Then I placed the ConTeXt-example with the LilyPond filter that I tried to compile in the same directory als the lilypond binary. Compiling it, as usual, from TeXShop it still did not start LilyPond and the .pdf still had: "[[output file missing"  where the musical example should have been.
However, compiling the file from Terminal did work.

Best regards,
Robert Blackstone









More information about the ntg-context mailing list