[NTG-context] placetable with location=split produces error (Christoph Reller)

Christoph Reller christoph.reller at gmail.com
Fri Jun 10 14:00:01 CEST 2016


On Thu, 09 Jun 2016 10:08:24, Christoph Reller
<christoph.reller at gmail.com> wrote:
> \starttext
>   \dorecurse{9}{\input ward}
>   \startplacetable[location=split]
>     \bTABLE
>       \bTR \bTD \input tufte \eTD \eTR
>     \eTABLE
>   \stopplacetable
> \stoptext
>
> The error message is:
>
> ! Undefined control sequence
> <argument> ...ixednumber {\currentfloat }\currentfloatnumber
>                                                   \relax
> \thecurrentfloatnum...
> \flushbothlabelclass #1#2#3->#1#3
>                                  #2
> \namedtaggedlabeltexts ...\dostarttagged {#1}{#2}}
>                                                   \dostoptagged \endgroup
> \thecurrentfloatnumber ...rentfloatnumbersuffix }}
>                                                   \fi \fi \fi
> \strc_floats_make_complete_caption ...floatnumber
>                                                   }\ifnofloatcaption \else
> \...
> \strc_floats_check_caption_content ...ete_caption
>                                                   }\ifdim \wd
> \b_strc_floats...
> ...

I have some additional information:

1. This error is also occurs when using the inline version:

    \placetable[split]{}{\bTABLE ... \eTABLE}

2. When adding \setupinteraction[state=start], then the error changes to:

! Missing number, treated as zero
<to be read again>
{
\strc_floats_place_packaged_boxes_indeed ...bute {
                                                  \doifelsemainfloatbody \cu...
\strc_floats_finish_placement ...e_packaged_boxes
                                                  \dostoptagged \global \d_p...
\syst_boxes_with_next_box ...mand {\box \nextbox }
                                                  \egroup \ifconditional \so...
\tabl_split_loop_body ...sult \tsplitafterresult }
                                                  \doifnotinsidesplitfloat \...
\syst_helpers_loop_yes ...helpers_recurse_content
                                                  \endofloop
...

3. This error happens in the currently latest version 2016.06.10_08:11
of context.
It is, however, also reproducible for earlier versions dating back at
least to 2015.06.12.

If there is any way I can help in resolving this issue then please let me know.

Kind regards,
Christoph


More information about the ntg-context mailing list