[NTG-context] Weird background colors in autogenerated index

Jan Tosovsky j.tosovsky at email.cz
Tue Apr 12 20:07:23 CEST 2016


On 2016-04-12 Hans Hagen wrote:
> On 4/11/2016 8:13 PM, Jan Tosovsky wrote:
> > On 2016-04-10 Hans Hagen wrote:
> >> On 4/10/2016 11:26 PM, Pablo Rodriguez wrote:
> >>> On 04/10/2016 11:00 PM, Jan Tosovsky wrote:
> >>>> On 2016-04-10 Hans Hagen wrote:
> >>>>> On 4/9/2016 11:22 PM, Jan Tosovsky wrote:
> >>>>>>
> >>>>>> since LuaTeXt 0.81 my back-of-the-book index (register) is
> >>>>>> with generated strange background colors. The index title
> >>>>>> is typeset in yellowish background and the left column of
> >>>>>> the last index page has a blue background.
> >>>
> >>> here you have the minimal sample:
> >>>
> >>>     \showgrid
> >>>     \starttext
> >>>     a\index{b}
> >>>     \completeindex
> >>>     \stoptext
> >>>
> >>> Comment the first line and colors background colors will 
> >>> disappear.
> >
> > My idea is to have a single PDF source to showcase some 
> > ConTeXt features, where displaying the grid is handy, yet 
> > allow disabling the grid on demand.
> 
> ... you can influence the grid a bit:
> 
> \showgrid[reset,...]
> 
> You're lucky that it's only a few lines to add 'columns' options 
> (so in some upcoming beta you have to mess with 'reset' 
> and whatever else).
> 

I am completely lost. I found page-grd.mkiv, but I have no idea what to tweak here.

By simple putting \showgrid[reset] at the beginning of the document no grid is shown, but those colored areas are present.

I am giving it up.

Jan




More information about the ntg-context mailing list