[NTG-context] TeX "matrix" command not working lately

L.S.-Soc&Gam axteffekt at gmail.com
Sun Apr 10 12:52:43 CEST 2016



Am 10.04.2016 um 12:39 schrieb Pablo Rodriguez:
> On 04/10/2016 11:45 AM, L.S.-Soc&Gam wrote:
>> [...]
>> I checked my version and it is the very same as yours.
>> Can you maybe give me the code that you tested, to create a matrix, so I
>> can copy paste and test it?
>> Because I entered a simple matrix again and still the finished pdf only
>> shows empty braces....
> Hi Sebastian,
>
> I copied and pasted your code adding \starttext...\stoptext:
>
>      \starttext
>      \startformula
>      S=\left(\matrix{
>        \sigma_x & \tau_{xy} & \tau_{xz} \cr
>        \tau_{yx} & \sigma_y & \tau_{yz} \cr
>          \tau_{zx} & \tau_{zy} & \sigma_z \cr
>      }\right)_{xyz}
>      \stopformula
>      \stoptext
>
> My guess is that the different results may be related to the OS.
>
> I’m on Linux 32bit using luatex-0.90.0. As far as I know, Windows is
> provided with luatex-0.95.0.
>
> This might be the cause of the different results. But it is only my
> guess. If this is the cause, you may have found a bug in luatex-0.95.0.
>
> I hope it helps,
>
> Pablo

A good point you've made there. I copied the code from above into a 
whole new document and compiled it. The result are *empty braces*.
That's interesting. So you might be right on the LuaTeX version 
difference issue. Anyway, Wolfgang's way works as well so I am going to 
use that technique for now. But this shouldn't be left standing like 
this I think.

Greetings, Sebastian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20160410/e7134b75/attachment.html>


More information about the ntg-context mailing list