[NTG-context] TeX "matrix" command not working lately

L.S.-Soc&Gam axteffekt at gmail.com
Sun Apr 10 12:06:00 CEST 2016



Am 10.04.2016 um 11:45 schrieb Wolfgang Schuster:
>> L.S.-Soc&Gam <mailto:axteffekt at gmail.com>
>> 10. April 2016 um 02:33
>> Hi guys,
>>
>> i've already searched the mailing list for this but i still am having 
>> a problem while trying to create a matrix.
>> my code looks like this:
>>
>> \startformula
>> S=\left(*\matrix**{*
>>   \sigma_x *&* \tau_{xy} *&* \tau_{xz} *\cr*
>>   \tau_{yx} *&* \sigma_y *&* \tau_{yz} *\cr*
>>     \tau_{zx} *&* \tau_{zy} *&* \sigma_z *\cr*
>> *}*\right)_{xyz}
>> \stopformula
>>
>> But since a few days, there are only empty braces after compilation. 
>> The funny thing is, i worked already. but i've updated context at 
>> least once since (only 5 days ago, betas included) and since then 
>> after compiling there are only empty braces. When i enter
>>
>> \startformula
>> S=\left(
>> 1234
>> \right)_{xyz}
>> \stopformula
>>
>> the 1234 shows fine between the braces. so it seems to have to do 
>> with \matrix command in some way...
>> i don't know any alternative way to create a matrix. any help would 
>> be appreciated.
> Your code works fine here but I suggest to use ConTeXt’s own matrix 
> environment.
>
> \starttext
>
> \startformula
> S =    \startmathmatrix[left=\left(,right=\right)]
>     \NC \sigma_{x} \NC \tau_{xy}  \NC \tau_{xz}  \NR
>     \NC \tau_{yx}  \NC \sigma_{y} \NC \tau_{yz}  \NR
>     \NC \tau_{zx}  \NC \tau_{zy}  \NC \sigma_{z} \NR
>     \stopmathmatrix_{xyz}
> \stopformula
>
> \stoptext
>
> Wolfgang
>
>
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
>
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : http://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________

Hi Wolfgang,

danke, your way works. Still I am a little bit confused why my previous 
(plain tex) matrix works for you guys but not for me, since it worked a 
few days ago. i hope that I am not missing anything here like for 
example that i forgot to define anything in the beginning.
So only for the record: my context version is 2016.04.01 13:01.
If anybody wants to research deeper into this, i can provide logs, texs 
and pdfs.

Thanks a lot,

Sebastian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20160410/aea6d120/attachment.html>


More information about the ntg-context mailing list