[NTG-context] Possible typo in source file type-imp-lato.mkiv

Hans Hagen pragma at wxs.nl
Wed Mar 16 17:05:23 CET 2016


On 3/16/2016 4:15 PM, Tom Harrop wrote:
> Hi,
>
> I was having trouble getting italics to work for a PDF that uses the
> Lato font. Bold and 'normal' were rendering just fine.
>
> In the log I saw some lines like:
>
>> fonts           > defining > font with asked name 'lato-reglta' is not
>> found using lookup 'file'
>> fonts           > defining > unknown font 'lato-reglta', loading aborted
>
> I noticed Context was searching for *reglta (with a lower case "L")
> rather than regita (with an "i").
>
> Looking at the file
> http://source.contextgarden.net/tex/context/base/type-imp-lato.mkiv I
> can see that all the synonyms point to *lta rather than *lta inside the
> \definefontsynonym commands.
>
> I tried changing all the instances of *lta to *ita in type-imp-lato.mkiv
> on two different systems (Ubuntu and MacOS) and in both cases I
> subsequently got italics in my PDF.
>
> I suppose this could be a bug. Is this list the right place to report it?

sure

> My apologies if it is in fact something I was doing wrong!

i'll fix it


-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
       tel: 038 477 53 69 | www.pragma-ade.com | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list