[NTG-context] issue with font loading

Pablo Rodriguez oinos at gmx.es
Wed Mar 2 13:07:27 CET 2016


On 03/02/2016 12:28 PM, Hans Hagen wrote:
> On 3/2/2016 12:11 PM, Pablo Rodriguez wrote:
>> [...]
>> I don’t get a sans typeface different from Latin Modern Roman.
>>
>> If the font is on the same directory as the ConTeXt source file, what is
>> wrong in my code?
> 
> doesn't the log tell you something

Many thanks for your reply, Hans.

searching for font in the log file, this is what I get:

fonts           > latin modern fonts are not preloaded
languages       > language 'en' is active
open source     > 2 > 3 > /home/ousia/a.tex
fonts           > preloading modern-designsize (math)
fonts           > typescripts > unknown library 'modern-designsize'
fonts           > 'fallback modern-designsize mm 12pt' is loaded
fonts           > preloading modern-designsize (mono)
fonts           > 'fallback modern-designsize tt 12pt' is loaded

used file       >    6: filename=lmroman10-regular.otf filetype=otf
format=otf
foundname=/home/ousia/ctxbeta/tex/texmf/fonts/opentype/public/lm/lmroman10-regular.otf
usedmethod=database

mkiv lua stats  > loaded fonts: 1 files: lmroman10-regular.otf
mkiv lua stats  > font engine: otf 3.013, afm 1.500, tfm 1.000, 4
instances, 3 shared in backend, 1 common vectors, 2 common hashes, load
time 0.060 seconds

Same results (no font embedding) with latest stable version from the
ConTeXt Suite.

If you want me to, I can attach the font itself in a private message (it
is URW Garamond [no copyright infringement, unless you plan to sell it
;-)]).

Many thanks for your help,

Pablo
-- 
http://www.ousia.tk


More information about the ntg-context mailing list