[NTG-context] (bug?) interactive link areas and \scale

Hans Hagen pragma at wxs.nl
Wed Feb 3 20:54:22 CET 2016


On 2/1/2016 7:37 PM, Pablo Rodriguez wrote:
> Dear list,
>
> [Sorry for sending many bug reports at once, but I’m not at home. I
> have my laptop and I’m working with it. Internet access is extremely
> limited here. I work offline and prepare all messages to be sent later
> when I can get some internet connection.]
>
> I have the following sample:
>
>      \setupinteraction[state=start]
>
>      \enabledirectives[references.border]
>
>      \def\mypersonalurl#1{\bgroup%
>          \tt\goto{\hyphenatedurl{#1}}[url(#1)]\egroup}%
>              \unexpanded\def\href#1#2{\goto{#2} [url(#1)]}
>
>      \starttext
>      \mypersonalurl{wiki.contextgarden.net}
>
>      \scale[width=.5\textwidth]
>          {\mypersonalurl{wiki.contextgarden.net}}
>      \stoptext
>
> The link area in latest beta is wrong when \scale is used (second
> link).
>
> Link area is fine with latest stable and beta from 2015.11.19 19:13. I
> don’t have all betas, but it appears in beta from 2015.12.20 00:29.

bug in luatex engine ... so you have to wait for an update

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
       tel: 038 477 53 69 | www.pragma-ade.com | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list