[NTG-context] ConTeXt on android via "debian noroot"-App

Mojca Miklavec mojca.miklavec.lists at gmail.com
Wed Jan 27 16:08:33 CET 2016


On 27 January 2016 at 14:26, luigi scarso wrote:
> On Sun, Jan 24, 2016 at 4:55 PM, Thomas Klein
> wrote:
>>
>> Hello ConTeXt-Crew,
>>
>> thank you very much for this fantastic application. I'm a former
>> LaTeX-user and now I can't imagine to go back ever.
>>
>> Recently I tried to install ConTeXt in an android smartphone with help of
>> the app "debian noroot". Everything went fine and I'm able to compile
>> documents, but all \framed-Commands lead to the error-message
>>
>> "tex error on line 2 in file...: !You can't use '\hrule' here except with
>> leaders"
>>
>> The minimal example is:
>>
>> \starttext
>> \framed{Hello}
>> \stoptext
>>
>> I suspect the cause for this might be missing packages (metapost?). Can
>> you give me any hint, what packages I have to install? I installed the
>> ConTeXt Standalone from contextgarden and I'm running context version
>> 2016.01.18 22:21 (ConTeXt Process Management 0.63). I already tried to
>> install the package texlive-metapost, but it didn't help.
>
> Confirmed on linux-armhf
> armv7l,
> installed with first-setup.sh.
>
> luatex --version
> 0.87.0
> context version
> 2016.01.18

I just tried it and exactly the same problem is also present on
Raspberry PI (which is where the binaries were built). It might be a
bit easier to debug there than on a phone.

Mojca


More information about the ntg-context mailing list