[NTG-context] ConTeXt on android via "debian noroot"-App

Mojca Miklavec mojca.miklavec.lists at gmail.com
Wed Jan 27 12:51:40 CET 2016


On 24 January 2016 at 16:55, Thomas Klein wrote:
> Hello ConTeXt-Crew,
>
> thank you very much for this fantastic application. I'm a former LaTeX-user
> and now I can't imagine to go back ever.
>
> Recently I tried to install ConTeXt in an android smartphone with help of
> the app "debian noroot". Everything went fine and I'm able to compile
> documents, but all \framed-Commands lead to the error-message
>
> "tex error on line 2 in file...: !You can't use '\hrule' here except with
> leaders"
>
> The minimal example is:
>
> \starttext
> \framed{Hello}
> \stoptext
>
> I suspect the cause for this might be missing packages (metapost?). Can you
> give me any hint, what packages I have to install? I installed the ConTeXt
> Standalone from contextgarden and I'm running context version 2016.01.18
> 22:21 (ConTeXt Process Management 0.63). I already tried to install the
> package texlive-metapost, but it didn't help.
>
> Help would highly be appreciated.

I'm unable to try this out both because my phone is too small and
because I don't have sufficient internal memory. Maybe I could borrow
a tablet and check.

Just curious: how did you install this and which binaries were
fetched? Did you use first-setup.sh that fetched linux-armel? Honestly
I'm completely amazed that it worked at all without any additional
work.

If you installed "texlive-metapost", that probably put the metapost
binary in a different location anyway and it might have problems
communicating with ConTeXt. If you are able to install packages from
debian, you could try "texlive-context" and see whether that one
works.

Mojca


More information about the ntg-context mailing list