[NTG-context] Error in latest beta: luat-exe.lua not found

Romain Diss romain.diss at yahoo.fr
Wed Jan 13 01:22:58 CET 2016


Le 13/01/2016, Hans Hagen a écrit
> On 1/13/2016 12:01 AM, Romain Diss wrote:
> >On 1/12/2016, Hans Hagen wrote:
> >>On 1/12/2016 9:33 PM, Romain Diss wrote:
> >>>I just downloaded the new beta and I can not launch context anymore. It
> >>>complains it can't find a 'luat-exe.lua' file:
> >>>>system          > lua > loading of file '/opt/context/tex/texmf-context/tex/context/base/luat-exe.lua' failed:
> >>>>         cannot open /opt/context/tex/texmf-context/tex/context/base/luat-exe.lua: No such file or directory
> >>>>resolvers       > lua > loading file '/opt/context/tex/texmf-context/tex/context/base/luat-exe.lua' failed
> >>>>error loading file: luat-exe.lua (aborting)
> 
> is that file sompelace on the system?
Yes, it is located in /opt/context/tex/texmf-context/tex/context/base/mkiv/luat-exe.lua

Concerning the 'context --version' error message, the 'context.mkiv' is
also located in /opt/context/tex/texmf-context/tex/context/base/mkiv/
and not in /opt/context/tex/texmf-context/tex/context/base/ as printed
in the output.

> 
> >>>As I can see, the 'base' directory has been split up into 'mkii' and 'mkiv'
> >>>subdirs, so maybe a link has not been updated.
> >>>Context end up with this message:
> >>>>This is LuaTeX, Version beta-0.87.0 (TeX Live 2016/dev)
> >>>>  system commands enabled.
> >>>>(Fatal format file error; I'm stymied)
> >>>
> >>>When I launch 'context --version', I get:
> >>>>mtx-context     | ConTeXt Process Management 0.62
> >>>>mtx-context     | main context file: /opt/context/tex/texmf-context/tex/context/base/context.mkiv
> >>>>mtx-context     | context version: unknown, load error
> >>i uploaded a version that reverts soem changes so that an older luatex works
> >>(we're still looking into the situation)
> >>anyway, this is unrelated to the mkii/mkiv sub path issue: i have no clue
> >>what happened at your end as i can update withou tproblems
> >>you can try to run mtxrun --generate and then update again
> >I ran again the 'first-setup.sh' script to upload the new version. There
> >do not seem to be any problem with the upload and installation. Anyway,
> >I get the same errors, even after running 'mtxrun --generate' and
> >updating again.
> >
> >Does a log file or another tests can help to find the problem?

-- 
Romain Diss


More information about the ntg-context mailing list