[NTG-context] suddenly run error

dr. Hans van der Meer havdmeer at ziggo.nl
Tue Jan 12 19:49:58 CET 2016


Earlier I posted the following error:

A document that runs fine under
   ConTeXt  ver: 2015.10.09 21:28 MKIV beta  fmt: 2015.10.11  int: english/english
suddenly doesn't under
  ConTeXt  ver: 2015.12.22 10:50 MKIV beta  fmt: 2015.12.27  int: english/english
mtx-context     | fatal error: no return code, message: luatex: execution interrupted

At first I thought this was due to a new version of ConTeXt. A mistake, it now seems. I encounter the same error in an earlier version. It seems therefore a problem already present in either LuaTeX or ConTeXt.

The error must be related to the placement of floats witness the following fact, typesetting the same document with only a difference in float-placement:

No error: \startplacetable[location=here,reference=tab:beaufort,title=Beaufort tabel]
Error: \startplacetable[location=page,reference=tab:beaufort,title=Beaufort tabel]

A further observation: the item placed is nearly filling the page. Making the item somewhat smaller avoids the error, even if its the only item on the page.

I did not succeed to compose a minimal example, in my experience the occurrence of the error seems too unpredictable. The actual project is far to complex and too big to be of use for debugging.

I sincerely hope someone can solve this. The error brings to mind a similar problem experienced years earlier. It then was a problem of a null object in the pdf-section, if my memory is correct and I think Taco has solved that.

Hans van der Meer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20160112/8bdd8bb9/attachment.html>


More information about the ntg-context mailing list