[NTG-context] Problem with first setup of StandAlone ConTeXt

Bruce Boghosian bruce.boghosian at tufts.edu
Tue Dec 15 13:47:18 CET 2015


Thank you very much for your replies.  I have now tried this, both with --context=beta, --context=current, and without a --context flag, and the result is always the same.  The command

$ sh ./first-setup.sh --context=current --modules=all --engine=luatex

returns many errors before giving the error message described.

I installed ConTeXt in $HOME/context/

Below are the requested outputs.  (My home directory has been replaced by [$HOME] in the outputs.)  Note that the first command hung.

$ cat $(kpsewhich context.mkiv) | grep edef.contextversion
warning: kpathsea: configuration file texmf.cnf not found in these directories: /sw/share/texmf/web2c/texmf.cnf.
^C
$ echo $PATH
/Users/[$HOME]/context/tex/texmf-osx-64/bin:/Users/[$HOME]/context/tex/texmf-osx-64:/Users/[$HOME]/texmf/scripts/context/lua:/usr/local/texlive/texmf-local/scripts/context/lua:/usr/local/texlive/texmf-local/tex/context/base:/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:
$ which luatex
/Users/[$HOME]/context/tex/texmf-osx-64/bin/luatex
$ which context
/Users/[$HOME]/context/tex/texmf-osx-64/bin/context
$ export | grep TEX
declare -x TEXMF="/Users/[$HOME]/.texmf-config:/Users/[$HOME]/.texmf-var:/Users/[$HOME]/Library/texmf:/sw/etc/texmf-config:/sw/var/lib/texmf:/sw/share/texmf-local:/sw/share/texmf:/sw/share/texmf-dist"
declare -x TEXMFCACHE="/tmp"
declare -x TEXMFCNF="/sw/share/texmf/web2c/texmf.cnf"
declare -x __CF_USER_TEXT_ENCODING="0x1F6:0x0:0x0"
$ 

Best regards,
Bruce



> On Dec 15, 2015, at 4:06 AM, Mojca Miklavec <mojca.miklavec.lists at gmail.com> wrote:
> 
> On 14 December 2015 at 17:37, Boghosian, Bruce wrote:
>> Dear ntg-context at ntg.nl:
>> 
>> I am new to ConTeXt, so if this is not a very good question, please accept
>> my apologies in advance.  I first tried sending this message to the help
>> address at contextgarden.net, and the reply I received suggested that this
>> list would be the more appropriate venue.
>> 
>> I am trying to install ConTeXt on my Mac, and am following the StandAlone
>> ConTeXt instructions on the page:
>> 
>> http://wiki.contextgarden.net/Mac_Installation#Installing_MacTeX
>> 
>> I installed MacTeX without problem, and then tried to follow the
>> instructions for Standalone ConTeXt.  At the end of Section 3.2 on that
>> page, when I tried to execute the command:
>> 
>> sh ./first-setup.sh --modules=all --engine=luatex
>> 
>> it ran for a minute or so, but ultimately gave me the error message copied
>> below.
>> 
>> This is LuaTeX, Version beta-0.85.0 (TeX Live 2016/dev) (rev 5550)  (INITEX)
>> system commands enabled.
>> (/sw/share/texmf-dist/tex/context/base/cont-en.mkiv
>> (/sw/share/texmf-dist/tex/context/base/context.mkiv
>> (/sw/share/texmf-dist/tex/context/base/syst-ini.mkiv
>> ! Undefined control sequence.
>> l.842     \pdfminorversion
>>                         \plusfive
>> ?
> 
> It might help to give us a bit more details. To me this sounds as if
> the wrong (some old) version of ConTeXt is being used. You already
> said that you didn't use --context=current. It might be that you have
> installed ConTeXt with Fink and that the old version from Fink is
> somehow taking precedence.
> 
> Can you please tell us where you installed the minimals and the output of:
> $ cat $(kpsewhich context.mkiv) | grep edef.contextversion
> $ echo $PATH
> $ which luatex
> $ which context
> $ export | grep TEX
> 
> Mojca
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
> 
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : http://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/ntg-context/attachments/20151215/99acb2c9/attachment.html>


More information about the ntg-context mailing list