[NTG-context] \reference and \setupinteraction[focus=...] not working

Christoph Reller christoph.reller at gmail.com
Fri Sep 18 08:34:49 CEST 2015


Hi,

Any news on this? Is this a luatex problem or a ConTeXt problem? I am glad
to help if you can point me to the location in the source code where things
go astray.

Cheers,
Christoph

On Mon, 14 Sep 2015 14:40:43 +0200, <christoph.reller at gmail.com> wrote:

> Hi,
>
> In the following MWE, the interactive link work only when setting
> focus=fit.
>
> The resulting PDF differs as follows:
>
> - focus=fit: This PDF has no named destinations. The link annotations on
> page 3 include destinations directly, and these destinations are correct.
>
> - focus=<something else>: This PDF has named destinations in Root->Names
> with names (#2) and (#3) and these named destinations are completely
> correct. The problem is that the link annotations on page 3 reference named
> destinations by the names (tuf) and (knu).
>
> \setupinteraction[state=start,focus=standard] %focus=fit
> \starttext
> \startsection[title=Hi There]
>   \reference[tuf]{Tufte}%
>   \input tufte
>   \page
>   \reference[knu]{Knuth}%
>   \input knuth
>   \page
>   \about[tuf] and \about[knu].
> \stopsection
> \stoptext
>
> This seems to be a bug. If so, then please confirm and tell if you intend
> to fix this.
>
> Interestingly, with focus=standard, automatically generated links (e.g.
> with sections and \about) work as expected.
>
> Regards,
> Christoph
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20150918/0a7dc286/attachment.html>


More information about the ntg-context mailing list