[NTG-context] noheaderandfooterlines messes with colors

Hans Hagen pragma at wxs.nl
Mon Aug 3 11:36:24 CEST 2015


On 8/3/2015 10:38 AM, Eric Détrez wrote:
> Le 01-08-2015 22:32, Aditya Mahajan a écrit :
>> On Sat, 1 Aug 2015, Eric Détrez wrote:
>>
>>> Here is a minimal example :
>>>
>>> \usemodule[tikz]
>>> \starttext
>>> \noheaderandfooterlines
>>> \starttikzpicture
>>>   \draw(0,2) node[color=red]{This should be red};
>>>   \draw(0,0) node[color=red]{This is red};
>>> \stoptikzpicture
>>> \stoptext
>>>
>>> The first line is written in black
>>> but when I comment \noheaderandfooterlines both lines are red
>>>
>>> This seems a curious effect
>>
>> Using \forcecolorhack works for this example:
>>
>> \starttikzpicture
>>   \forcecolorhack
>>    \draw(0,2) node[color=red]{This should be red};
>>    \draw(0,0) node[color=red]{This is red};
>> \stoptikzpicture
>>
>> Aditya
>
> It seems there is a problem :
> tex error       > tex error on line 3 in file
> /home/ericd13/documents/Context/essaicouleur.tex: ! Leaders not followed
> by proper glue
>
> <to be read again>
> \hskip
> \forcecolorhack ->\leaders \hrule \hskip
>                                           \zeropoint \relax
>
> I use context minimal

\hbox\bgroup\forcecolorhack\starttikzpicture
   \draw(0,2) node[color=red]{This should be red};
   \draw(0,0) node[color=red]{This is red};
\stoptikzpicture\egroup


-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list