[NTG-context] No output for no apparent reason

Wolfgang Schuster schuster.wolfgang at gmail.com
Mon Aug 3 09:18:06 CEST 2015


> Matt Gushee <mailto:matt at gushee.net>
> 3. August 2015 07:52
> Hello, ConTeXt people--
>
> I am coming back to ConTeXt after a long absence (for about the 3rd or 
> 4th time - maybe if I just stuck with it I wouldn't keep having these 
> problems, eh?).
>
> I have a new installation of the standalone ConTeXt package on an Arch 
> Linux system. I obtained the 'first-setup.sh' script according to 
> instructions, then ran:
>
>     ./first-setup.sh --modules=all --engine=luatex --context=current
>
>  I also have TeXlive, including ConTeXt, installed as a regular Arch 
> package; however, I don't intend to use it. In any case, I have 
> sourced /opt/context/tex/setuptex, so I have:
>
>     $ which context
>     /opt/context/tex/texmf-linux-64/bin/context
>
>     $ context --version
>     mtx-context     | ConTeXt Process Management 0.61
>     mtx-context     |
>     mtx-context     | main context file: 
> /opt/context/tex/texmf-context/tex/context/base/context.mkiv
>     mtx-context     | current version: 2015.05.18 12:26
>
> I have tried the "hello world" example described on the wiki, and the 
> output from that is exactly as expected, but I am having trouble with 
> a couple of projects that I created in 2006. Each project is 
> moderately complex, including an environment file and several product 
> files. Each project produced output in the past. But now I run 
> 'context <file>', and there are no obvious errors (except for fonts 
> not found, but in that case the default font should be used instead, 
> correct?), yet no PDF is produced.
>
> Furthermore, the log files say that PDF files were generated, e.g.:
>
>     mkiv lua stats > result saved in file: hobo.pdf, compresslevel 3, 
> objectcompresslevel 3
>
> And yes, I've checked the modification times on the log files, and 
> they are up to date.
>
> Of course I am not giving very much detail, but I have no idea what 
> might be relevant. Any ideas about how to troubleshoot this?
>
Is it possible that your main file of your document is a project?

When this is the case change this file to a product and all subfiles 
into components.

Wolfgang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20150803/552ba7a2/attachment.html>


More information about the ntg-context mailing list