[NTG-context] footnotes when using RtL (Arabic)

talazem at fastmail.fm talazem at fastmail.fm
Sun Aug 2 12:02:43 CEST 2015


Apologies: While the problem remains, I realise now that using "method=one" or "method=two" wasn’t having any effect because I had forgotten to add the option "align=righttoleft,” to "\setupnotations[lnote]”. Having done so, adding the method options do have an effect. But the output is still flawed; the beginning of the third note is missing at the end of the first line of the footnote, while its last few words can be seen on the second line of the footnote. See my new attachment (linenotes r2l 3,tex) below:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: linenotes r2l 3.tex
Type: application/octet-stream
Size: 1637 bytes
Desc: not available
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20150802/1965dc27/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: linenotes r2l 3.pdf
Type: application/pdf
Size: 10002 bytes
Desc: not available
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20150802/1965dc27/attachment.pdf>
-------------- next part --------------



> On 2 Aug 2015, at 10:20, talazem at fastmail.fm wrote:
> 
> Thank you, Pablo, for bringing method=two to my attention. I’ve read what has been written about in on the mailing list. However, in my case, it does not solve the problem. On the document I’ve attached:
> - using method=default produces the error I raised yesterday;
> - using method=one (or method=two) seem to do nothing — the parentheses are still inversed, as if I hadn’t defined \setupdirections at all. See attached:
> 
> <linenotes r2l 2.tex><linenotes r2l 2.pdf>
> 
> 
> Talal
> 
>> On 2 Aug 2015, at 08:52, Pablo Rodriguez <oinos at gmx.es> wrote:
>> 
>> On 08/02/2015 12:36 AM, talazem at fastmail.fm wrote:
>>> I’ve run into a hiccup. In the previous MWE that worked with Woflgang and
>>> Hans’ patch, the notes were footnotes. However, if make them into
>>> linenotes, we run into a strange problem: the first note is typeset
>>> correctly, but all the remaining linenotes in that stream are typeset on
>>> the bottom left corner of the page. See attached files.
>> 
>> Hi Talal,
>> 
>> I experienced this issue before (although r2l languages are all Greek to
>> me :-().
>> 
>> \setupdirections[bidi=global, method=two] seems to fix the problem.
>> 
>> I hope it helps,
>> 
>> 
>> Pablo
>> -- 
>> http://www.ousia.tk
>> ___________________________________________________________________________________
>> If your question is of interest to others as well, please add an entry to the Wiki!
>> 
>> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
>> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
>> archive  : http://foundry.supelec.fr/projects/contextrev/
>> wiki     : http://contextgarden.net
>> ___________________________________________________________________________________
> 



More information about the ntg-context mailing list