[NTG-context] can't run external lua library

luigi scarso luigi.scarso at gmail.com
Thu Jul 23 09:30:09 CEST 2015


On Thu, Jul 23, 2015 at 1:37 AM, DesdeChaves <desdechaves at gmail.com> wrote:

> I'm trying to reuse a old library to generate poisson numbers. In old
>  context versions the library works fine, but in the current  beta (ConTeXt
>  ver: 2015.07.16 13:30 MKIV beta  fmt: 2015.7.23  int: english/english) the
> execution fails.
>
> This code works perfectly in lua 5.3 but not in luatex. why?
>
> \startluacode
>
>
> require "meurandist"
> ARRAY_SIZE=3
> arr=meurandist.new_int(ARRAY_SIZE)
> meurandist.rpoisson(arr,ARRAY_SIZE,4)
> for i=0,ARRAY_SIZE-1 do
> print(meurandist.int_getitem(arr,i))
> end
>
>
> \stopluacode
>
>
> Thanks a lot
>
>

luatex 0.80.1 (the latest luatex) still uses lua 5.2.4

-- 
luigi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20150723/07f6c795/attachment.html>


More information about the ntg-context mailing list