[NTG-context] fonts not found with newotf

Hans Hagen pragma at wxs.nl
Mon Jul 20 00:31:50 CEST 2015


On 7/19/2015 1:27 PM, Pablo Rodriguez wrote:
> Hans,
>
> as reported in a previous message, using beta from 2015.07.16 13:30,
> enabling the newotf module in the following sample makes the Mechanica
> fonts not being loaded in the final PDF document:
>
>      \usemodule[newotf]
>
>      \definefontfamily
>         [txfont]
>         [tt]
>         [Mechanica]
>         [tf=file:Mechanica.otf,
>          it=features:slanted,
>          sc=file:MechanicaSC.otf]
>
>      \setupbodyfont[txfont]
>
>      \starttext
>      \tt Test {\it amfe} {\sc amfe}
>      \stoptext
>
> The attached newotf-error.log contains the error message.
>
> Since both font files were generated with FontForge, I would like to
> know what they are missing to report upstream to the FontForge developers.

there seems to be a cid entry operator seen when populating a private 
dictionary in the cff section

you can add this in line 552 of font-cff:

                     cid               = {
                         -- actually an error
                     },

and the font will probably load then, unless there is a fundamental flaw 
(i don't know where to get that font)

Hans


-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list