[NTG-context] definereferencestructureprefix for floats

Aditya Mahajan adityam at umich.edu
Mon Jun 22 17:34:22 CEST 2015


On Mon, 22 Jun 2015, Wolfgang Schuster wrote:

>
>> Aditya Mahajan <mailto:adityam at umich.edu>
>> 22. Juni 2015 05:35
>> On Sun, 21 Jun 2015, Aditya Mahajan wrote:
>> 
>> 
>> Even the second example in strc-ref.mkvi does not work correctly.
>> 
>> \starttext
>>     \chapter{test}
>>     \placefigure[here][xx:1]{}{\framed{one}} 
>> \placefigure[here][xx:2]{}{\framed{three}}
>>     \placetable [here][xx:3]{}{\framed{two}} \placetable 
>> [here][xx:4]{}{\framed{four}}
>>     \start
>>         \in{fig}[xx:1] and \in{fig}[xx:2] \in{tab}[xx:3] and \in{tab}[xx:4]
>>     \stop \blank \start
>>         \setupreferencestructureprefix[default][prefix=no]
>>         \in{fig}[xx:1] and \in{fig}[xx:2] \in{tab}[xx:3] and \in{tab}[xx:4]
>>     \stop \blank \start
>>         \setupreferencestructureprefix[float][default][prefix=no]
>>         \in{fig}[xx:1] and \in{fig}[xx:2] \in{tab}[xx:3] and \in{tab}[xx:4]
>>     \stop \blank \start
>>         \setupreferencestructureprefix[figure][default][prefix=no]
>>         \in{fig}[xx:1] and \in{fig}[xx:2] \in{tab}[xx:3] and \in{tab}[xx:4]
>>     \stop \blank
>> \stoptext
>> 
>> The second case, (\setup...[default][prefix=no]) works correctly, but the 
>> last two cases (\setup...[float][default][prefix=no], etc) do not get rid 
>> of the prefix.
> Did you fix the typo in strc-ref.lua and regenrate the format?

Yes. Do these two example work correctly for you with the latest beta 
(after fixing the typo and generating the format)?

Aditya


More information about the ntg-context mailing list