[NTG-context] \placeongrid command

Csikos Bela bcsikos425 at freemail.hu
Thu May 14 17:37:21 CEST 2015


Hello list members:

Based on co-pagedesign.pdf document I'm experimenting with grids.

I followed the examples mentioned on page 9-10 (Section 1.5) and used the code below:

%begin code
\setuplayout[grid=yes]
\showgrid

\starttext

This is a line.

This is another line in another paragraph.

Third line, new paragraph again.

\placeongrid{\framed{This is a framed line placed on grid, default setup.}}

Some text.

\placeongrid[bottom]{\framed{This is a framed line placed on grid bottom.}}

Some text.

\placeongrid[top]{\framed{This is a framed line placed on grid top.}}

Some text.

\placeongrid[both]{\framed{This is a framed line placed on grid both.}}

Some text.

\stoptext
%end code

All \placeongrid commands with different options give the same output.
See the attached pdf file.
What do I do wrong?

I have context ConTeXt
ver: 2014.01.03 00:40 MKIV current fmt: 2015.4.1 int: english/english

I have another question related to grids. When grids are shown in the pdf
file (as a result of \showgrid), Adobe Reader 9.5 (linux version) always gives
the following error message when opening the file:

"An error exists on this page. Acrobat may not display the page correctly. Please
contact the person who created the PDF document to correct the problem."

Despite of the message the file is shown correctly.

Why is this message shown?

Thanks,

bcsikos
-------------- next part --------------
A non-text attachment was scrubbed...
Name: placeongrid.pdf
Type: application/pdf
Size: 22125 bytes
Desc: not available
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20150514/0646367e/attachment-0001.pdf>


More information about the ntg-context mailing list