[NTG-context] System fonts not loading

Mica Semrick mica at silentumbrella.com
Sun Apr 26 23:57:30 CEST 2015


Hello,

I seem to be having some trouble getting the system fonts to load from my Debian Jessie system.

I'm using:

mica at box:~/Working$ context -version

mtx-context     | ConTeXt Process Management 0.61
mtx-context     |
mtx-context     | main context file: /home/mica/.context/tex/texmf-context/tex/context/base/context.mkiv
mtx-context     | current version: 2015.04.18 14:41

and OSFONTDIR is set and all the fonts I want to use are in ~/.fonts:

mica at box:~/Working$ echo $OSFONTDIR
/home/mica/.fonts/

Usually when I run into font problems or add a new font, I run:

fc-cache -fv
mtxrun --generate
context --make

This has worked for some time, however now it will not. Consider the following:

\definefontfamily [junction] [rm] [Junction Regular]
\definefontfamily [junction] [mm] [Latin Modern Math]

\setupbodyfont[junction]

\starttext

\input ward \bf \input ward
\tf \input ward \bf \input ward
\stoptext

which results in a pdf with Latin Modern.

mtxrun --script fonts --list --all doesn't seem to be seeing the OS fonts, but sees all of ConTeXt's fonts. However, fc-list : family (which will list all the system fonts known by fc-cache) shows all the fonts as available.

Thank you for any help.

Best,
Mica


More information about the ntg-context mailing list