[NTG-context] Bug with macro tightfunction (Metafun)

Pablo Rodriguez oinos at gmx.es
Mon Feb 16 21:26:17 CET 2015


On 02/16/2015 06:00 PM, Fabrice Couvreur wrote:
> Hi,
> This code generates an error while it was working fine a month ago.

Hi Fabrice,

MP is too much fun for me ;-)). I mean, this is all Greek to me.

I can only report that I get an empty page with both the latest beta
from 2015.02.03 23:55 and beta from 2014.11.26 21:43.

Just in case it might help,


Pablo


> \definecolor[mycolor][c=.4,m=0,y=0,k=0]
> 
> \starttext
> \start
> \switchtobodyfont[small]
> \startMPcode
>      input hvdm;
>      input tex;
>      l:=3mm; r:=0.6; alfa:=45; beta:=0; gamma:=0;
>      defineDefaultArrow (l, r, alfa, beta, gamma);
>      numeric xmin, xmax, ymin, ymax;
>      xmin := 0; xmax := 110; ymax :=8000 ;ymin:=0; u := 0.1cm; v:= 0.002cm;
>      color mycolor; mycolor:=(0.4,0,0);
>      drawoptions(withpen pencircle scaled 0.3pt withcolor
> \MPcolor{mycolor});
>      draw hlingrid(ymin,ymax,1000,16cm,11cm);
>      draw vlingrid(xmin,xmax,10,11cm,16cm);
>      pickup pencircle scaled 1pt ;
>      arrowline ((xmin,0) -- (xmax,0)) scaled u;
>      arrowline ((0,ymin) -- (0,ymax)) scaled v;
>      drawoptions(withpen pencircle scaled 1pt);
>      draw tightfunction ("x", "x*x-84*x+5000", 0, 100, 0.01) xyscaled (u,v);
>      for i=0 step 10 until 100:
>          label.bot(TEX("$"&decimal(i)&"$"),(i*u,0));
>      endfor;
>      for i=0 step 1000 until 7000:
>          label.lft(TEX("$"&decimal(i)&"$"),(0,i*v));
>       endfor;
>    label.top("Nombre de lots",(90u,50v));
>    label.lrt(btex $f(x)$ (en euros) etex,(0,7800v));
> \stopMPcode
> \stop
> \stoptext


-- 
http://www.ousia.tk


More information about the ntg-context mailing list