[NTG-context] Setup for appendices: a bunch of questions

Mojca Miklavec mojca.miklavec.lists at gmail.com
Fri Feb 6 09:20:41 CET 2015


On Fri, Feb 6, 2015 at 9:09 AM, luigi scarso wrote:
> On Fri, Feb 6, 2015 at 8:59 AM, Mojca Miklavecwrote:
>>
>> (Well, my computer hoplessly crashed when I first tried it, but I hope
>> it's not your code to be blamed ;)
>>
> A crash (ie a seg. fault, or an infinite loop)
> with context ?

It's way too off-topic, but first my pdf viewer crashed while context
was still compiling the document, luatex was stuck in the middle of
compiling. I used Ctrl+C to break the compilation, but there was a
ghost process still there. I tried to remove the new code, then start
context again. It was stuck again, I had to use Ctrl+C to stop
compilation and there was again a new ghost luatex process in the
background. I tried "kill -9 <pid>", but it didn't help. I tried to
force kill it in the GUI, no success either. Then I tried "rm
filename.pdf" and the "rm" process was stuck as well, forever. Finally
I tried to reboot the machine, but it refused to reboot, so I had to
shut it down the hard way (press the switch-off button for a long
time, an equivalent of removing the battery).

I don't think that any of that had anything to do with ConTeXt or
luatex. It sounds like a hardware issue to me (despite my first
thought that I ended up in an infinite loop).

----------

Back on topic. If I move a figure to Appendices, the figure now gets
numbered as "1.V" (I would want to see "B.1" if it's the first figure
in Appendix B). But when I reference that figure in main text, it
becomes "Figure 1.5" which is indistinguishable from another figure
"1.5" in the first chapter.

Mojca


More information about the ntg-context mailing list