[NTG-context] Where is error in my code?

Hans Hagen pragma at wxs.nl
Wed Jan 28 10:37:18 CET 2015


On 1/28/2015 5:49 AM, Van Dung Tang wrote:
> I edit 1 file metafun with follow:
>
> \startMPenvironment
> \usetypescript[times][texnansi]
> \switchtobodyfont[times,10pt]
> \stopMPenvironment
> \startMPpage
> fill fullcircle scaled 2cm withcolor red;
> label(\sometxt{Cn},origin) withcolor white;
> \stopMPpage
>
> After run context and recieve 1 picture with a space very very long at
> left my picture.

if you use mkiv you can do just:


\switchtobodyfont[times,10pt]

\startMPpage
     fill fullcircle scaled 2cm withcolor red;
     label(\sometxt{Cn},origin) withcolor white;
\stopMPpage

if you use mkii, you have to load the fonts first

\startMPenvironment[global]

because loading can involve all kind of actions that introduce spaces

Hans


> Please help me find my error!
> Thanks
>
>
>
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
>
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : http://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________
>


-- 

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list