[NTG-context] pagebreak after columns

Hans Hagen pragma at wxs.nl
Fri Jan 9 23:01:16 CET 2015


On 1/9/2015 9:29 PM, Thomas A. Schmitz wrote:
> Hi all,
>
> a somewhat belated happy new year to all of you!
>
> I’ve come across what seems to be a very old bug (I have found references to it in the mailing list from about 10 years ago): I get an unwanted page break after every column environment. Here’s an example with two different ones:
>
> \definecolumnset [mine] [n=2,balance=no,distance=1cm]
>
> \definemixedcolumns [mycolumns] [n=2,balance=no,distance=1cm]
>
> \starttext
>
> \input ward
>
> \startcolumnset [mine]
>
> \input ward
>
> \column
>
> \input ward
>
> \stopcolumnset
>
> \input ward
>
> \page
>
> \input ward
>
> \startmycolumns
>
> \input ward
>
> \column
>
> \input ward
>
> \stopmycolumns
>
> \input ward
>
> \stoptext
>
> Is this fixable? Thanks, and all best

that's how balance=no works: in that case \column will go to a next 
column but still fill to the bottom

columnsets is actually not meant to be used mixed unless in controlled 
situations (maybe i will redo columnsets in mkiv some day)

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list