[NTG-context] system fonts access under macosx (again)

j. van den hoff veedeehjay at googlemail.com
Tue Dec 23 17:42:37 CET 2014


as advised I have installed standalone context in order to get better  
support of system fonts under macosx.
I now have had the following happen to me:

1.
after installation of `standalone' and straightening out unrelated  
problems with `\usemodule' usage I managed to get proper
support of -- that's the specific font I wanted to use -- the `Optima'  
font family. Notably I got italics
where I wanted them. so far so good.

2.
then I discovered that standalone context does not include the very nice  
`EB Garamond' font (although
there are some files in the context tree apparently related to tweaking  
some things related to this font) -- contrary to
texlive where `context` finds this font just fine.

3.
instead of putting this font into the standalone `context' tree (which I  
tried initially without luck -- on second thought
I probably would have needed to do a `mtxrun --script fonts --reload' ...)  
I installed these (otf) fonts systemwide.

(as an aside: is there a way of notifying standalone context of the  
location of the `texlive' font directories?)

4.
contrary to what I seem to have read in the documentation somewhere (??)  
the fonts were than _not_ looked up "on demand" (i.e.
where not found automatically when compiling the document wanting to use  
this font) but only found after I did a manual `mtxrun --script fonts  
--reload'

5.
now `ebgaramond' works fine _but_ out of the `Optima' fonts now only the  
regular font is found and reported by `mtxrun ... fonts`
if I interpret this output correctly:

optima          optimaregular   /System/Library/Fonts/Optima.ttc   index:   
4
optimanormal    optimaregular   /System/Library/Fonts/Optima.ttc   index:   
4
optimaregular   optimaregular   /System/Library/Fonts/Optima.ttc   index:   
4

so I seem back to square one in this respect :-(.
I can only assume that this has been caused by the `--reload' run (see  
item 1. above: intitially `optima' italics worked) and/or maybe still
fragile support of these `ttc' (true type collection) files? just a guess.

what am I doing wrong _this_ time?

thx,

joerg

-- 
Using Opera's revolutionary email client: http://www.opera.com/mail/


More information about the ntg-context mailing list