[NTG-context] Loading modules (was: access to system fonts under MacOSX)

Wolfgang Schuster schuster.wolfgang at gmail.com
Mon Dec 22 22:35:43 CET 2014


> Am 22.12.2014 um 00:12 schrieb j. van den hoff <veedeehjay at googlemail.com>:
> 
> OK, I've just installed the standalone version and adjusted my search path. now the very same document does no longer compile. I get the error:
> 
> 8<---------------------------
> ! Undefined control sequence
> 
> <recently read> \doctitle
> 
> l.106    \doctitle
> 8<---------------------------
> where `doctitle' is defined in a small bare bones module (co-existing in the same dir as the doc) for setting up a title page. I guess I'm hitting some (context-) searchpath issue here that already is taken care of in the texlive distro? any help'd be appreciated.

I guess you load the file with your definitions with the \usemodule command.

There has been a change a while ago and context expects now a prefix
when you load a module (e.g. p-<myfile>.tex) and when you add now the
prefix to your file context will be able to load it. Another solution is to add

    \enabledirectives[modules.permitunprefixed]

before the \usemodule command in your document, the command
above tells context to also look for modules without a prefix as last resort.

Wolfgang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20141222/c0e0e1fd/attachment-0001.html>


More information about the ntg-context mailing list