[NTG-context] PSTricks in Context

luigi scarso luigi.scarso at gmail.com
Tue Dec 16 10:32:55 CET 2014


On Mon, Dec 15, 2014 at 3:27 PM, Mojca Miklavec <
mojca.miklavec.lists at gmail.com> wrote:
>
> On Mon, Dec 15, 2014 at 12:53 PM, Herbert Voss wrote:
> > Am 15.12.2014 um 09:55 schrieb Mojca Miklavec:
> >
> >> Anyway, the version in TeX Live now runs, but creates wrong results
> >> (it prints out "(0,0)(3,3)" instead of drawing the line for example).
> >>
> >> (And I'm not too eager to add support for PSTricks to the
> >> distribution. It's a "can of worms" with zillion of other utilities
> >> that we don't ship. And close-to-zero users.)
> >
> >
> > huh?? The only problem is this line
> >
> > \loadpstrickscolors{colo-rgb}}
> >
> > as mentioned in my mail.
>
> The problem is that this is not the only problem ;)
>
> Or at least that didn't solve all the problems for me.
>
> First of all I had to use Kakuto-san's example, adding something like
>
> \pspicture(0mm,0mm)(30mm,30mm)
> ...
> \endpspicture
>
> in front and at the back (which is extremely ugly to see in ConTeXt).
>
> So the complete minimal example was:
>
> \usemodule[pstricks]
> \starttext
> \startPSTRICKS
> \pspicture(0mm,0mm)(30mm,30mm)
> \psline(0,0)(3,3)
> \endpspicture
> \stopPSTRICKS
> \stoptext
>
> However that still doesn't work with TeX Live 2014 even after fixing
> the issue with mkii in the filename:
>
> ! Missing } inserted.
> <inserted text>
>                 }
> <to be read again>
>                    \endgroup
> \endpspicture ...]\fi \fi \pst at killglue \endgroup
>                                                   \egroup \ifdim \wd
> \pst at hb...
> l.12 \endpspicture
>
> According to Kakuto-san it works with the latest ConTeXt, but I need a
> bit of tweaking to try it out and even if it does users would need to
> install (at least part of) W32TeX, wait for TLContrib to release a
> newer version of ConteXt or tweak themselves in order to try it out.
>
> Mojca
>

I have downloaded
cont-mpd.zip  cont-ppc.zip  cont-tmf.zip
and unzipped them into
texmf-dist of my 2014 TL (and rebuilt the formats and ls-R).
I have tried mtxrun --script update but it fails with
resolvers       | tds | no 'texmf-linux-64' under tree
'/opt/luatex/texlive/2014/tex'
(with a missed newline in my linux box)

The example works if one copies colo-rgb.mkii as colo-rgb.tex in the same
folder of the example
so I guess that we need to find a suitable location for colo-rgb.tex in the
tds
(I dont know if it's safe to add colo-rgb.tex to the base folder of
context, but I suspect it is not)


-- 
luigi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20141216/669d94ad/attachment.html>


More information about the ntg-context mailing list