[NTG-context] position of qed symbol in proofs

Mikael P. Sundqvist mickep at gmail.com
Sun Nov 9 21:29:12 CET 2014


On Sat, Nov 8, 2014 at 5:43 PM, Otared Kavian <otared at gmail.com> wrote:
> Hi Mikael,
>
> In my files I have the following which used to work, but it doesn’t work as expected anymore, as you point out
>
> \defineenumeration[proof][text=Proof.]
>
> \setupenumeration[proof]
>         [number=no,
>         closesymbol=\mathematics{\square},
>         closecommand=\ifmmode\eqno\else\wordright\fi]
>
>
> \starttext
> \startproof
> This is a simple proof.
> \stopproof
>
> \startproof
> This is another simple proof that ends with a formula
> \startformula
> 1+1=2.
> \stopformula
> \stopproof
> \stoptext
>
> I don’t know when the change occurred, but at least it worked last year (which for ConTeXt means pregistoric times… :—).
> As a temporary hack one can always say:
> \startformula
> 1+1=2. \eqno{\square}
> \stopformula
>
> Best regards: OK
>
>> On 08 Nov 2014, at 14:40, Mikael P. Sundqvist <mickep at gmail.com> wrote:
>>
>> On Mon, Nov 3, 2014 at 9:15 PM, Mikael P. Sundqvist <mickep at gmail.com> wrote:
>>> Hi,
>>>
>>> I once used
>>>
>>> \defineenumeration[proof][
>>> text=Proof,
>>> closesymbol=\mathematics{\square},
>>> closecommand=\ifmmode\eqno\else\wordright\fi,
>>> ]
>>>
>>> \starttext
>>> \startproof
>>> This is a simple proof.
>>> \stopproof
>>>
>>> \startproof
>>> This is another simple proof that ends with a formula
>>> \startformula
>>> 1+1=2.
>>> \stopformula
>>> \stopproof
>>> \stoptext
>>>
>>> to get the \square at the end of proofs, and it worked out well. But
>>> with the latest beta (and some previous one(s)), the \square is not
>>> placed at the same line as the formula in the second example. Is it
>>> broken? Or is there a new syntax?
>>>
>>> PDF with my result is attached.
>>>
>>> Best regards, Mikael
>>
>> I don't like to bump, but... Noone else has this problem?
>>
>> @Hans: Is it easily fixed?
>>
>> /Mikael
>> ___________________________________________________________________________________
>> If your question is of interest to others as well, please add an entry to the Wiki!
>>
>> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
>> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
>> archive  : http://foundry.supelec.fr/projects/contextrev/
>> wiki     : http://contextgarden.net
>> ___________________________________________________________________________________
>
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
>
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : http://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________

Hi Otared,

thank you for looking at this. It feels good that it is not only me
who has this problem. As far as I remember, this issue was not present
3-4 weeks ago.

/Mikael


More information about the ntg-context mailing list