[NTG-context] pgfplots broken?

Keith J. Schultz keithjschultz at web.de
Wed Nov 5 12:22:17 CET 2014


Hi Mikeal, Hans, All,

This is indeed strange as I can confirm that the code works with TeXLive 2014.

I checked my latest Standalone updates this morning.
I am running it on a MacBook Pro with clean installed Yosemite and latest
Xcode. I use TeXShop to use TeX, et al. 

The files are indeed there:

/Users/quayjay/context/tex/texmf-modules/tex/generic/pgf/libraries/luamath/pgfluamath.parser.lua
/Users/quayjay/context/tex/texmf-modules/tex/generic/pgf/libraries/luamath/pgfluamath.functions.lua

and

/usr/local/texlive/2014/texmf-dist/tex/generic/pgf/libraries/luamath/pgfluamath.parser.lua
/usr/local/texlive/2014/texmf-dist/tex/generic/pgf/libraries/luamath/pgfluamath.functions.lua

interesting parts of log file from standalone run:

mtx-context     | warning: synctex is enabled
mtx-context     | run 1: luatex --fmt="/Users/quayjay/context/tex/texmf-cache/luatex-cache/context/5fe67e0bfe781ce0dde776fb1556f32e/formats/luatex/cont-en" --jobname="Ohne-Titel1" --lua="/Users/quayjay/context/tex/texmf-cache/luatex-cache/context/5fe67e0bfe781ce0dde776fb1556f32e/formats/luatex/cont-en.lui" --no-parse-first-line --synctex=1 --c:autogenerate --c:currentrun=1 --c:fulljobname="./Ohne-Titel1.tex" --c:input="./Ohne-Titel1.tex" --c:kindofrun=1 --c:maxnofruns=8 --c:synctex="1" "cont-yes.mkiv"
This is LuaTeX, Version beta-0.79.1 (TeX Live 2014/dev) (rev 4972) 
 \write18 enabled.
open source     > 1 > 1 > /Users/quayjay/context/tex/texmf-context/tex/context/base/cont-yes.mkiv
job             > passes > version mismatch: 1.25 <> 1.27

ConTeXt  ver: 2014.11.04 19:10 MKIV beta  fmt: 2014.11.5  int: english/english

[snip, snip]

open source     > 5 > 70 > /Users/quayjay/context/tex/texmf-modules/tex/generic/pgfplots/pgfplotscore.code.tex
open source     > 6 > 71 > /Users/quayjay/context/tex/texmf-modules/tex/generic/pgfplots/sys/pgfplotssysgeneric.code.tex
Package pgfplots notification 'compat/show suggested version=true': document has been generated with the most recent feature set (\pgfplotsset{compat=\mostrecent }).

close source    > 6 > 71 > /Users/quayjay/context/tex/texmf-modules/tex/generic/pgfplots/sys/pgfplotssysgeneric.code.tex
close source    > 5 > 71 > /Users/quayjay/context/tex/texmf-modules/tex/generic/pgfplots/pgfplotscore.code.tex

[snip, snip]

open source     > 6 > 75 > /Users/quayjay/context/tex/texmf-modules/tex/generic/pgf/libraries/luamath/pgflibraryluamath.code.tex

lua error       > error on line 75 in file /Users/quayjay/context/tex/texmf-modules/tex/generic/pgf/libraries/luamath/pgflibraryluamath.code.tex:

.../context/tex/texmf-context/tex/context/base/util-lib.lua:246: module 'pgfluamath.functions' not found:
	no field package.preload['pgfluamath.functions']
	no file '/usr/local/share/lua/5.2/pgfluamath/functions.lua'
	no file '/usr/local/share/lua/5.2/pgfluamath/functions/init.lua'
	no file '/usr/local/lib/lua/5.2/pgfluamath/functions.lua'
	no file '/usr/local/lib/lua/5.2/pgfluamath/functions/init.lua'
	no file './pgfluamath/functions.lua'
	no file '/usr/local/lib/lua/5.2/pgfluamath/functions.so'
	no file '/usr/local/lib/lua/5.2/loadall.so'
	no file './pgfluamath/functions.so'
	no file '/usr/local/lib/lua/5.2/pgfluamath.so'
	no file '/usr/local/lib/lua/5.2/loadall.so'
	no file './pgfluamath.so'
stack traceback:
	[C]: in function 'savedrequire'
	.../context/tex/texmf-context/tex/context/base/util-lib.lua:246: in function 'require'
	[\directlua]:1: in main chunk


1) I can not be sure that the pgfplot notification has anything to do with our problem. But, I doubt it.

2)  no field package.preload['pgfluamath.functions']
     Now, this msg does give me concern, they should have been preloaded or am I missing something!

3) I look at the different versions of pgfluamath,functions.lua
   and noticed then has been new logic introduced. So, the problem
   might be a programmers error from PGF-code somewhere. 

Personally, I do not think this is a problem with ConTeXt not finding files, but
a problem in the PGF-Code itself. That is some tables are not being set up right.


Hope this helps.

Keith J. Schultz
  
     
> Am 04.11.2014 um 16:32 schrieb Hans Hagen <pragma at wxs.nl>:
> 
> On 11/4/2014 12:42 PM, Mikael P. Sundqvist wrote:
>> Hi, pgfplots seems broken with the latest standalone.With the example
>> 
>> \usemodule[pgfplots]
>> \starttext
>> Foo
>> \stoptext
> 
> Is there a "pgfluamath.*" file on the system?
> 
> Hans
> 
> 
>> Best regards, Mikael
>> 
>> lua error       > error on line 75 in file
>> /opt/ConTeXt/tex/texmf-modules/tex/generic/pgf/libraries/luamath/pgflibraryluamath.code.tex:
>> 
>> .../ConTeXt/tex/texmf-context/tex/context/base/util-lib.lua:246:
>> module 'pgfluamath.functions' not found:
>>     no field package.preload['pgfluamath.functions']
>>     no file '/usr/local/share/lua/5.2/pgfluamath/functions.lua'
>>     no file '/usr/local/share/lua/5.2/pgfluamath/functions/init.lua'
>>     no file '/usr/local/lib/lua/5.2/pgfluamath/functions.lua'
>>     no file '/usr/local/lib/lua/5.2/pgfluamath/functions/init.lua'
>>     no file './pgfluamath/functions.lua'
>>     no file '/usr/local/lib/lua/5.2/pgfluamath/functions.so'
>>     no file '/usr/local/lib/lua/5.2/loadall.so'
>>     no file './pgfluamath/functions.so'
>>     no file '/usr/local/lib/lua/5.2/pgfluamath.so'
>>     no file '/usr/local/lib/lua/5.2/loadall.so'
>>     no file './pgfluamath.so'



More information about the ntg-context mailing list